Security Settings in MS-Excel Prohibit XL Reporter

Asked By 1660 points N/A Posted on -
qa-featured

Hi! I am using Microsoft Excel to receive the exported report of our inventory application. Just this morning when I am about to generate a report and export it to Microsoft Excel I received an error message: Security settings in Microsoft  Excel prohibit XL Reporter from running.

 

XL Reporter

Security settings in Microsoft  Excel prohibit XL Reporter from running.

From more information, click Help.

As I looked on the error message above, I don't know what setting shall I fix with my Microsoft Excel. By the way, the computer that I am using now has just been reformatted.

Please share your ideas on what settings should I work on. If possible can it be stated in a step by step fashion?

Thanks a lot.

SHARE
Best Answer by Noel Sam
Answered By 0 points N/A #122144

Security Settings in MS-Excel Prohibit XL Reporter

qa-featured

Error above arises when Microsoft Excel settings of Macro Security is configured as High or Very High.

To solve you may follow steps below:

  • OPEN Ms Excel / Select TOOLS / OPTIONS / SECURITY TAB / (Macro Security Box appears) / SELECT MEDIUM in Security Level.
  • In TRUSTED PUBLISHER TAB / SELECT (Trust access to Visual Basic Projects and Trust all installed add-ins and templates) / OK

I hope it works.

Best Answer
Best Answer
Answered By 0 points N/A #122147

Security Settings in MS-Excel Prohibit XL Reporter

qa-featured

You got these messages because when Macro Security Settings in MS Excel are configured as High / Very High.

Solution:

Open your MS Excel

Click on Tools > Choose Options and select Security Tab.

Next, select Macro Security > Here you select Security Level Medium.

Now, From Trusted Publishers Tab chooses 2 options:

  • Trust access to Visual Basic Project
  • Trust all installed add-ins and templates

Then Click on OK.

NB: After solve this issue you may got this kind of message.

“A required COM add-in program for XL Reporter has not been loaded and prohibits Microsoft Excel from running”

Solution:

a. Open MS Excel

b. From Tools menu, select Customize.

c. You see Command pane on the Right and select COM add-ins command.

d. Close Customize window.

e. From Tools Menu select the new COM Add-ins option

f. Here, select Add to open the Add

g. Choose the IXXL Reporter.dll file from Client Directory then choose OK.

h. From COM Add-ins window chooses XL Reporter checkbox and select OK.

Thank You.

Login/Register to Answer

Related Questions