Microsoft Communications Managed API failed to install

Asked By 10 points N/A Posted on -
qa-featured

Hi Brainy,

When I attempt to install the Microsoft Communications Managed API 4.0 on a Windows Server 2012, I ended up with this error message. Is this requires any specific system requirements before installation? Am I missing anything? I am doing this in Windows server 2012, think this is supported. Help me to fix the error. Thanks for your help.

Error :

Setup has detected that this computer does not meet the requirements to install this software. The following blocking issue must be resolved before you can install Microsoft Unified Communications Managed API 4.0, Runtime software package.

Installation Requirements:

Microsoft Unified Communications Managed API 4.0, Runtime required the following missing Windows Features.

• Media Foundation

SHARE
Answered By 564910 points N/A #188397

Microsoft Communications Managed API failed to install

qa-featured

That’s right. You get this error because your system doesn’t meet all the requirements needed for the Microsoft Unified Communications Managed API 4.0. The software requires that your computer is already installed with Microsoft Media Foundation which is a feature in Microsoft Windows Server 2012. It seems that by default, the Media Foundation feature is disabled.

You only need to enable it to install the feature on the computer. You can install this feature through PowerShell by running this command:

  • Install-WindowsFeature Server-Media-Foundation

Alternatively, you can also add Media Foundation using the Server Manager. Open Server Manager. You can also open it by finding and double-clicking the file “ServerManager.exe”. Next, go to Manage, Add Roles and Features, and then click Next until you reach the Add Roles and Features Wizard screen. Scroll down and find Media Foundation, select it, click Next, and then Install. See image.

And that’s it. Microsoft Media Foundation is now installed. You can now install Microsoft Unified Communications Managed API 4.0.

Login/Register to Answer

Related Questions