The managed object model version” error

Asked By 10 points N/A Posted on -
qa-featured

 

During the test of the previous versions of a cocoa app-Smultron, a publisher of developer's text that usually worked big but now it is much buggy – I found next the error:

I am running Mac X OS and I added new first core data application to learn how to develop applications for Mac OS but I got this following error message when I tried to start this application. What should I do now?

I really need your help as soon as possible.

Any suggestion would be greatly appreciated.

Thanks.

The managed object model version used to open the persistent store is incompatible with the one that was used to create the persistent store.

The managed object model version used to open the persistent store is incompatible with the one that was used to create the persistent store.

Please guide to resolve this error soon ..

 

SHARE
Best Answer by Robert F McMiller
Best Answer
Best Answer
Answered By 0 points N/A #138923

The managed object model version” error

qa-featured

To fix this error, you have to remove the XML file and also have to rebuild the application. Your document will be automatically removed in the case when data are based on the document. The user will have to find a code that has the ability to make a store subject  to find any file location. Mostly the default location is $(home)/Library/Application Support/APP-NAME)/.

Answered By 0 points N/A #198955

The managed object model version” error

qa-featured

Hi Joseph,
The error is because address to data file Contour used to store screenplay information is missing.
The solution to this error is :
1) Locate the file ‘Contour.xml’
2) In finder, Select ‘Go to Finder’. A text field will appear
3) Paste the path ~/Library/Application Support/Contour/ in the text field, press enter
4) Delete ‘Contour.xml’, empty the trash

Login/Register to Answer

Related Questions