Mac OS X TextEdit Error

Asked By 0 points N/A Posted on -
qa-featured

Lately, I get this error every time I open Mac's text edit program. At first, I just ignored it but after a few times of seeing it, I got frustrated and had to fix the error. The error is below.

 
This Document Could not be autosaved because you don't have write access privileges to the folder that it's in.
 
I tried saving the file by save-as but still the same results. I also tried permissions, repair and it was not working as well. 
 
Then I tried doing a Get Info on a blocked folder. Clicked the lock icon in the lower right corner. It asked me for a password. Once unlocked, I set the permissions for "everyone" to Read Only. And still it did not work! 
 
Please advise.
SHARE
Best Answer by Balram
Best Answer
Best Answer
Answered By 0 points N/A #87837

Mac OS X TextEdit Error

qa-featured

The folder named 'autosave' is in is the "Library" folder. The Sharing and Permissions of the "Library" folder is "Administrator: Read and Write. Everyone: No Access."

I am logged in as the administrator so if I am reading correctly, I should have complete access and permission. (also the autosave folder has the permissions of "System: read and Write, Everyone: no access. For some reason this text is opaque, meaning I cant change it.

Answered By 0 points N/A #87839

Mac OS X TextEdit Error

qa-featured

Hi,

In order to solve this issue go to same location in the problem user and you will red minus sign on the folder. That means that you don't have access to it. 

Now follow these steps:

  • File/Get info revealed
  • System Read and Write
  • Everyone no access

From here you can change the access privileges of the given folder or file. I hope that you find the solution to the problem.

Regards,

Peter Franklin

Answered By 0 points N/A #87841

Mac OS X TextEdit Error

qa-featured

The biggest the problem, the simplest could be a solution!

Your auto-save option is currently on. You shall try to save files manually (“Ctrl+S” option).

Now to stop auto-saving files, go to home folder then to Library and delete the "Auto-save Information" folder which should fix your problem.

Don’t forget to save manually else you may not able to recover the file again.

Answered By 0 points N/A #87843

Mac OS X TextEdit Error

qa-featured

 

Hi,

For this particularly problem you can follow the following easy steps. With this you will not encounter the same problem again.

You need first to ad yourself (your username) to the Autosave  List of the folder:

1.     Go to <your_hard_drive>=><Users>=><your_username>=>”Library”=> “Autosave information”

2.     From here get info on the Autosave Information folder clicking on the lock icon.

3.     Authethicate and add your <username> to the list.

4.     Now add Read & Write permission.

This will fix your problem.

Thanks,

Aabel

Login/Register to Answer

Related Questions