Mac Error: Applications Quits Unexpectedly

Asked By 0 points N/A Posted on -
qa-featured

The application Firefox quit unexpectedly.

Mac OS X and other applications are not affected.

Click Relaunch to launch the application again.  Click Report to see more details or send a report to Apple.

Ignore                              Report….                                  Relaunch

I’ve recently encountered a very disturbing problem in my Mac OS X Leopard, where the applications quit unexpectedly without notice and fails on re-launch attempt. At first it happens to Firefox, Photoshop and a few applications that I frequently use; it then crashes other applications like Adium, Mail client, Font Book and apps that I hardly use.

SHARE
Best Answer by ManTechA
Best Answer
Best Answer
Answered By 0 points N/A #87727

Mac Error: Applications Quits Unexpectedly

qa-featured

If you did any recent hardware or software installations, try to uninstall it and disconnect the hardware you just connected or installed. Then run the Apple Hardware Test, to check for possible hardware issues.

Run the Apple Hardware Test that came with the Mac system, probably labeled as Mac OS X Install Disc 1 DVD. Insert it in the disk drive and restart your Mac. When you see it starting to boot press and hold  “C” on your keyboard. After a few seconds, the Apple Hardware Test will appear and will start to load.

Once you finish running the Apple Hardware Test, try to run an Extended Test afterwards, to make sure that any possible issue/s can be detected.

Answered By 50 points N/A #87728

Mac Error: Applications Quits Unexpectedly

qa-featured

 

This problem is similar to Window’s "illegal operation" that causes software to shutdown automatically without notice. You know you are a victim when an application shuts down by itself, and when you clicked Relaunch and it will still eventually shut down. Almost any application will behave like that.
 
  • Go to Disk Utility, select your harddrive, and click Verify Disk (or Repair Disk if necessary) 
  • System Preferences -> Dock
  • Minimize using: Scale Effect
  • Unchecked both "Animate opening applications", "Automatically hide and show the Dock" 
  • If you are using Adium Instance Messenger, go to Preferences -> Advanced tab, under Contact List, un-check Animate Changes. 

Login/Register to Answer

Related Questions