Logmeinhamachi Error: Lost Connection To The Engine

Asked By 90 points N/A Posted on -
qa-featured

I have installed Hamachi, but it is acting weirdly. I have no idea what happened to it as it is getting an error saying,

Hamachi has lost the connection to the engine. I tried to restart both the application and my computer, but it does not change anything at all.

This error pops up every time Hamachi is opened.

Am I the only one experiencing the issue?

If not, can anybody give any suggestion to resolve this?

 

Error:

Hamachi has lost the connection to the engine 

SHARE
Best Answer by Carl Jack
Best Answer
Best Answer
Answered By 0 points N/A #159133
qa-featured

Hello Hanley,

The error you are getting could be occurring because the service LogMeIn Hamachi 2.0 Tunneling Engine has not been started just yet. To start it, you will need to do the following:

  • First you will need to go to Manage
  • And then choose services
  • After that you will need to start the tunneling engine auto/manual

If that does not help, the problem could be with the registry key called EngineConfigDir. You can find that key in the following locations:

  • HKEY_LOCAL_MACHINESOFTWARELogMeIn HamachiEngineConfigDir
  • HKEY_USERS.DEFAULTSoftwareLogMeIn HamachiEngineConfigDir

In both locations, this key should have the following value: C:Documents and SettingsDefault UserLocal SettingsApplication DataLogMeIn Hamachi

Do the following:

  • You will need to create a new directory, C:Program FilesLogMeIn Hamachiconfig
  • And then you will change both EngineConfigDir values in the registry to C:Program FilesLogMeIn Hamachiconfig
  • After that you will restart the Hamachi service and see if you can successfully start the GUI.

Regards,

Carl

Answered By 0 points N/A #159134
qa-featured

I manage around 10 clients on hamachi subscription.  A few days ago there was an update to the hamachi product and ever since all of my clients have been displaying the subject error message.  The service is started and all my connections to hamachi endpoints are working.  Only the display of the GUI doesn't work.  This seems to be an ongoing problem with this product.  Originally I had this problem when I switched to another profile and tried to start the GUI, I would get the error message.  When I switched back to the profile where I installed it under it worked fine. 

So I have noticed in the registry pointer "EngineConfigDir" is now pointing to C:Windowssystem32configsystemprofileAppDataLocalLogMeIn Hamachi.  If you browse to that directy you will see all of your config info there instead of a local profile directory or default profile directory like it used to be. 

A quick solution to this problem (until hamachi fixes this bug) is to go to services, find the LogMeIn Hamchi Tunneling Engine service and STOP it, then RESTART it.  Then open the hamachi GUI. 

Answered By 550615 points N/A #159132
qa-featured

You might need to check the stability of your connection. This problem occurred maybe because of an interruption in your connection. Try checking your internet connection by opening any of your web browsers then visit some websites. You may also want to try watching some streaming videos to see if your connection is stable and doesn’t encounter any gaps or interruption. Try opening Hamachi again if you think your connection is stable.

If the problem happened again, try checking your computer for any possible errors. Use a disk utility application to check the system. After this start Hamachi again. If still nothing happened, try upgrading the program. If you are using an older version of the application, try installing Hamachi 2.1.0.215. You can download the latest version by visiting Softonic® – Enjoy Software! | Hamachi. This version supports Windows 2000, Windows XP, Windows Vista, Windows 7, and Windows 8.

Login/Register to Answer

Related Questions