Linux debian: remote desktop connection error

Asked By 0 points N/A Posted on -
qa-featured

Hi ,
this is a problem connecting from my Windows 7 Professional to Debian Linux using Remote Desktop Connection. I saw this error message “Because of a protocol error, this session will be disconnected. Please try connecting to the remote computer again.”

I tried VNC and it works fine. Unfortunately VNS works fine only when the user on remote machine is logged in. It does not work when is logged off. That is why I need to use Remote Desktop Connection.

I have tested it using Windows XP Pro SP3 and it works fine. Even when the user on remote machine was logged off, I was able to connect to my Debian and log in.
 It means that the issue is only on Windows 7 Pro. The Debian Linux configuration is fine.
Can anyone help me to solve the issue?

Thank you in advance for your help.

 

Remote Desktop Connection

Because of a protocol error, this session will be disconnected. Please try connecting to the remote computer again.

SHARE
Best Answer by Allen Kenneth
Answered By 0 points N/A #123383

Linux debian: remote desktop connection error

qa-featured

Hi dear,

There are numerous rdp connection programs that you can use to make Windows 7 and Debian to work together without getting errors.

A good example of a partner software that you can use are:

Nx Client for Windows

OpenSSH for Linux

For the nx client program, there is an ordering in downloading.

-nxclient

-nxnode

-nxserver

You also need to install them in this exact order.

download nx client here: Download Link

After getting this nxclient, all you have to do is to assure that your linux machine has an OpenSSH program.

Then you can proceed in configuring the OpenSSH in your linux machine.

Hope it would help you.

Best Answer
Best Answer
Answered By 0 points N/A #123385

Linux debian: remote desktop connection error

qa-featured

Hello Lisa, 
 

This problem usually occurs if Remote Desktop Connection Client version 6.0.6001 /  6.0.6002 is used with the highest RDP Compression setting. 
 
Here is a solution. Try this.
 
On the server, change the RDP Compression setting to the recommended "Balances memory and network bandwidth" or "Optimized to use less memory" using Group Policy.
 
 If you are using Windows Server 2008 R2, you would also choose "Do not use an RDP compression algorithm". 
 
Below mentioned are steps to make the change to the local group policy; In this case, you can use a domain group policy as well.
 
* On Windows Server 2008 R2
 
1. First logon [as an administrator] to the "RD Services Session Host" computer
2. Start > Run gpedit.msc
3. In the left side, under the "Computer Configuration", follow this path:
 
Administrative TemplatesWindows ComponentsRem.Desktop ServicesRem. Desktop Session HostRem. Session Environment
 
4. In the right side, Click on Set compression algorithm for RDP data and open.
5. Select "Enabled" & choose "Balances memory & network bandwidth"
6. Click OK and proceed to save the changes
 
* On Windows Server 2008 (SP1 or SP2)
 
1. First you have to logon [as an administrator] to the "Terminal Services computer" 
2. Start > Run gpedit.msc, click "Continue" if  it is prompted by UAC
3. In the left side, under the "Computer Configuration", follow this path:
 
Administrative TemplatesWindows ComponentsTerminal ServicesTerminal ServerRem. Session Environment
 
4. In the right side, Click on Set compression algorithm for RDP data and open.
5. Select "Enabled" & choose "Balances memory & network bandwidth"
6. Click OK and proceed to save the changes

Hope this will help you! 

 

 

Login/Register to Answer

Related Questions