Limited Connectivity and No Internet Connection

Asked By 0 points N/A Posted on -


I have a Toshiba laptop, specs are as follows:

Processor: [email protected] 1.83GHz 1.83 GHz.

Installed Memory (RAM) : 2.5 GB.

System Type: 32 Bit Operating System.

No pen or touch input is available on display.

I am using Windows 7 Professional.

I don't know the root of the problem, but every time I try to connect to our wireless internet, I will be getting a message that I have LIMITED CONNECTIVITY  and/or NO INTERNET ACCESS.  I already tried to download the latest version of the wireless driver ,but that does not solve the problem. 

I was thinking maybe the Ethernet card is defective. But when I try to use cable and connect it directly to the router internet is OK and works alright.  And it is also important to note that other pc/laptops are able to connect with this router with no problem at all. 

What causes this problem and how do I solve this?

Thank you.

Best Answer by shenna22
Answered By 0 points N/A #79981

Limited Connectivity and No Internet Connection


Hey Red,

  • The problem you mentioned I seems its not the problem of your PC or Laptop, when the option comes about limited connectivity and no internet connection means something is  wrong at user side, so check them first that IPS are  pity well assigned specially in the case of LAN big LAN network,
  • If still the problem remained than you should ask from your ISP that the problem is occurring they will guide you also some tricks and trips and you have to learn them, as they will be important later on . 
  • Limited connectivity option I mostly comes when no proper signals or the system is off at the network side.

Hope this information will be helpful to you,



Best Answer
Best Answer
Answered By 0 points N/A #79982

Limited Connectivity and No Internet Connection



Good day, I read your issue about your wireless network connection, to fix this problem; this is the steps to be followed.

  1. Go to start menu and look control panel and find Administrative tools.
  2. Find and click services, and you will see the “Services(Local)”
  3. Just go to the lowest and find “Wireless Zero Configuration” right click if the services are “Automatic” just click “Start”. Then right click again a go to “Properties”.
  4. Set the startup type “Automatic”..APPLY and OK.
  5. Close out the services and go back to the control panel. Find “network connection” and find your “Wireless Network Connection”.
  6. Right click on it and set into “Enabled”. Right click on it just go properties to the “Wireless Network Connection”.
  7. Check the “Use Windows to Configure your Wireless setting” click OK and its will done.

I hope this step will help you

Good luck And you can do it.



Login/Register to Answer

Related Questions