Latest Windows Live messenger Upgrade

Asked By 0 points N/A Posted on -
qa-featured

I use XP SP3. I have a Messenger Live Version 2009. I installed  the latest version but had an error. I just really want to know how to install or upgrade to latest version.

 

 

SHARE
Best Answer by Puckett Buckner
Answered By 0 points N/A #126878

Latest Windows Live messenger Upgrade

qa-featured

You can download Windows Live Messenger here Download Link1

The requirements for this application are :

  • 1.6 GHz or higher processor.
  • 1 GB memory or higher memory
  • Resolution: 1024 x 576 minimum
  • Internet Connection

Try to reprogram your PC if it's not compatible with xp sp3. Windows XP nowadays are phased out already.

Try using Windows Vista or Windows 7 if your computer has high specs, if not, stock on Windows XP 🙂

Best Answer
Best Answer
Answered By 0 points N/A #126879

Latest Windows Live messenger Upgrade

qa-featured

Hello,

I believe you have a Windows XP and that sounds great! Windows Messenger live is available with that operating system though Movie Maker and slide show feature for photo gallery are not supported by XP.

To start the upgrade just simply go to http://www.filehippo.com/download_msn_messenger/

Click on “Download Latest Version” at the upper right hand corner of the page which will bring you to another window and will automatically download the new software.

Another link I can suggest as an alternate solution is: https://a1-downloads.phpnuke.org/en/c10712/windows-live-messenger-free-download-full-reviewI address your inquiry.

Good luck!

Thank you.

Puckett

Answered By 558070 points N/A #283035

Latest Windows Live messenger Upgrade

qa-featured

I think I see the problem. If you have Windows XP Service Pack 3 and you have Windows Live Messenger 2009, there should be no problem. This version still supports Microsoft Windows XP. Windows Live Messenger 2009 supports Windows XP (32-bit only), Windows Vista, Windows 7, Windows 8, and Windows 10 both 32-bit and 64-bit.

windows-live-messenger-2016

The next stable version after Windows Live Messenger 2009 is Windows Live Messenger 2011 but unfortunately this version no longer supports your operating system. Windows Live Messenger 2011 has the same set of supported operating systems as with version 2009 but excluding Windows XP.

The version in between, Windows Live Messenger 2010, is in beta version so I don’t think this is the one you downloaded and installed that got the error because if you download the messenger from the official website which is Microsoft, the beta version is usually not made available for download. It is only available and intended for beta testers for bug discovery.

Since you are using Windows XP, you are stuck with Windows Live Messenger 2009 because it is the last version to support Windows XP. Windows Live Messenger dropped support for Windows XP beginning in the first beta version of Windows Live Messenger 2010. In case you are using a different operating system now, you can download the latest version from Windows Live Messenger on FileHippo.

The latest is Windows Live Messenger 2016 build 16.4.3528 and it supports Windows 7, Windows 8, and Windows 10 both 32-bit and 64-bit.

Login/Register to Answer

Related Questions