No of visitors who read this post: 7774
Type: Question
Author: Stacy Lenox
Your rating: None Average: 5 (14 votes)

I have this weird issue going on with my laptop. I am currently doing an article for our school paper, so I am typing this on Microsoft Word 2007. I am in the middle of my composed article when all of a sudden, whenever I pressed L on my keyboard, my laptop locks.

There is the same issue with the other keys, it just that it opens another program or explorer opens. So I am trying to find the issue with my mouse. I think it has something to do with keyboard shortcuts, so I checked it, but I think the configuration is fine. Besides, there is no shortcut configured for my computer to lock with just the letter L. Patiently,

I continued doing the article with just the copying and pasting the previously typed letter L, but I am tired of it. Even restart won’t fix it. The article is already done on another computer as well as posting my problem on this site. I want my laptop back in shape. Is there anyone out there who can fix my keyboard issues?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 11444

I think you got a problem with the windows key on the keyboard. You can have many shortcuts by using the Windows key. Well for your knowledge I want to mention that, Windows key + L is the shortcut for locking the machine.

Windows key + R for Run dialog box.

Windows key + E for Windows explorer.

And there are so many shortcuts to do many functions.

Check your keyboard whether a Windows key is pressed.

Try to clean your keyboard using defined cleaning methods. As this is a laptop there are specific tools to clean laptop keyboards. But it's better to give it to some expert to service your laptop for maintenance and cleaning. I think your problem is sensor of the Windows key is always touched into the surface.

So now let me tell you about some facts about the Windows key. It is also known as the Super key, Logo key, Meta key, Win key, Start key or flag.

This key becomes a standard key on computer keyboards, from the release of the Win 95 by Microsoft. Same as the Windows key, you can get another key like the Apple key for Mac keyboards.

The windows key is placed between the CTRL and ALT on the left side and, ALT and menu key on the right side. (You will find the menu key is an also an important key in the keyboard).

Pressing and releasing the Windows key by itself opens the Start Menu.

  • Win+B select the 1st icon in the Notification Area.
  • Win+D show desktop.
  • Win+E Windows Explorer opens.
  • Win+F Windows Search opens.
  • Win+F1 Windows Help open.
  • Win+L lock desktop or switch users.
  • Win+M all window minimizes.
  • Win+ Shift+M restore windows which were minimized with Win+M.
  • Win+R Run dialog box open.
  • Win+Pause or Win+Break System Properties open.

So now just press each of the keys above without the Windows key and you can clearly identify whether the Windows key is the real issue here.

There is another solution for this problem.

If you cannot mend it on the keyboard, you can disable the windows key from the registry.

You can go to this site and download the registry entry file and install it on your machine.

Click here or else you can do this manually.

Follow the below steps to disable the Windows key.

Click Start.

Go to Run.

Type regedt32 and then click OK.

Follow the below path in registry editor.

HKEY_LOCAL_ MACHINE\System\CurrentControlSet\Control folder, and then click on the Keyboard Layout folder.

Click on the Edit menu.

Click Add Value.

Type of Scancode Map.

Click REG_BINARY as the Data Type and then OK.

Type 00000000000000000300000000005BE000005CE000000000 in the Data field and then OK.

Close Registry Editor and restart the machine.

So here after your Windows key is disabled.

To enable it, follow the below steps:

Click Start.

Click Run.

Type regedt32 and then OK.

Go again the above mentioned path.

Right-click on the Scancode Map registry entry and then Delete it.

Close Registry Editor and then restart the machine.

For your information, I want to tell you about another thing.

Onscreen keyboard. A virtual Keyboard displays on the screen.

Click Start.

Go to All Programs.

Click Accessories.

Go to Accessibility and there you see On-Screen keyboard.

So now you can press keys from your mouse pointer. I'm sure that this utility also be very much valuable for you.

# Comment Id: 50785

Hi Stacy,

There are multiple solutions in solving your problem. Try following this one.

Solution # 1

Look at your keyboard. Some laptops have a function key that will lock the keyboard. You need to press the [Fn] key and the appropriate [F#] key. In my laptop the combination would be [Fn+F1] keys. If it shuts down to re-activate the keyboard you looses everything you have worked on that aren't being saved.

Solution # 2

Hold CAPS LOCK and press the touchpad disable switch.

Solution # 3

Press windows logo key or click start button and the letter L key at the same time to lock or unlock the keyboard. (This usually works).

Solution # 4

Look to see if you have any key with "ALT" on it - regular keys - also look for a key with "NumLck" on it. To deactivate press and hold the ALT key and press the Numlck key.

Solution # 5

The reset 'button' on a laptop is a small hole through which a switch can be pressed using a straightened paper clip as you note. Could be almost anywhere - on a couple of HP laptops I have owned/used the reset 'button' was on the base or on the LH side.

That's it. Hope these are helpful.

Now try this one if the solutions above doesn't solve your problem. This is a bit confusing but just follow using Registry Editor.

Open up regedit.exe through the start menu search box, and then browse down to the following key, creating it if it doesn’t exist:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

Disable lock workstation

On the right-hand side, create a new DWORD 32-bit value named DisableLockWorkstation and give it one of these values:

  • 1 – Disable Lock Workstation.
  • 0 – Enable Lock Workstation.

The changes should take effect immediately and no need to restart anything.

Well then, I hope this solves the issue.