Language problem on Google Earth?

Asked By 0 points N/A Posted on -
qa-featured

i use Google earth for many reason. If I go to countries where they don't speak English as their first language then all the landmarks and such are in their language. I have tried changing language to English but it still does it? How can I change it ,so its all in English?

SHARE
Best Answer by Jordan_Johnson
Answered By 0 points N/A #84887

Language problem on Google Earth?

qa-featured

Hello ,

  • Go to Google Earth
  • Six words will appear on the tool bar .From the left select fourth word ->tools and then choose the section fifth one down ->options 
  • You will get a pop up window. 
  • Click on the last tab ->General. 
  • In the left column, second row is "Language". 
  • Choose first option from drop down list->System Default 
  • You will see a notice box pop up.  Press the button in the popup menu. 
  • Yu will find 4 buttons on the option window, Select ->Restore Defaults, then click Apply and then OK.
  • Restart the Google Earth
  • If you still find system default is not working, try selecting English US or English UK options and this will change the language to English.

This will help you.

Best Answer
Best Answer
Answered By 0 points N/A #84888

Language problem on Google Earth?

qa-featured

Hey Tarance,

  • First of all, check if you are using Version 4 or later, if it is the case you don't need to download another version of Google Earth to use another language.
  • To change the language displayed in Google Earth, click Tools > Options (Mac: Google Earth > Preferences). Click the General tab. Under Language settings, choose the appropriate language of your choice.

Login/Register to Answer

Related Questions