Keyboard producing different keys from the ones typed

Asked By 360 points N/A Posted on -
qa-featured

I am experiencing a strange problem with my keyboard. I keep on receiving characters on the screen different from the ones I type on the keyboard. I installed a new keyboard but still the problem persists. For instance, if I type “a” it would be displayed as low. “w” would output ro/. The trend is that I get more than one letter on the screen when I punch a single letter.

All this started happening after I trying out the Windows XP Remote Assistance feature with a friend’s laptop. My PC developed the complication during the connection.

I issued remote control permission to my friend’s laptop. He opened my MSN 7 window and clicked on the drawing thing. When I clicked on the typing option, the problem occurred. The keyboard was not giving the right response to the keys pressed. I can’t restore the system to an earlier point when it was functioning well because I never enabled the System Protection feature on my drive C.

I have tried troubleshooting options but none of them can either identify or fix the problem. I really don’t know what might be causing this problem. I don’t want to format my computer either.

Can someone help please?

Thanks.

SHARE
Best Answer by Peter Kent
Best Answer
Best Answer
Answered By 0 points N/A #106878

Keyboard producing different keys from the ones typed

qa-featured

It seems that it modifies the layouts of your keyboard for different languages, that’s why the characters that displays on your monitor does not match up the characters that you pressed on the keyboard.  The main function of the keyboard layout is that it manages what characters to display on your screen whenever a certain key is pressed on the keyboard.

This keyboard layout also allows you to use all the characters for the desired language. To fix this issue, select your operating system and follow the steps.

For Windows XP

  1. Access the control panel on start menu.
  2. Select switch to classic view found at the left pane if your default setting is category view.  Classic View shows all the options that you can select.
  3. Locate Regional and Language Options.
  4. From the window, select the “Languages” tab
  5. Select the “Details” button, another window will appear.
  6. On the “Settings” tab, under Installed services, click “Add” button.
  7. An “Add Input Language” window will appear.
  8. From the drop down menu, select an Input language and Keyboard layout/IME that you want.
  9. Click the “OK” and “Apply” button

For Windows Vista

  1. Access the control panel on start menu.
  2. Switch to “Classic view” and select “Regional and Language Options”
  3. Select Keyboards and Language tab and click the Change Keyboards.
  4. Under “Text Services and Input Languages” select “General” tab and click default input language drop down menu and choose the desired language to use.
  5. If you can’t find the language under “secondary language” click “Add”. From the drop down menu, select an Input language and Keyboard layout/IME that you want.
  6. Click the “OK” and “Apply” button

For Windows 7

  1. Go to Start menu and select control panel.
  2. Select the “Region and Language” from the icon lists.
  3. Select the “keyboards and Languages” tab.
  4. Click “Change keyboards” button.
  5. Under "Input Language" and select "Add" button to select from the list of the "Add Input Language"
  6. Click the OK button twice.

 

  1. Another way is, from the task bar select the Language bar and choose an "input language" for the keyboard layout you will use.
  2. Or by pressing the ctrl+alt+delete, on the screen menu select the "Keyboard layout" from the list and select input language" for the keyboard layout you will use.

If none of this works, you have to conduct a system repair on your computer. A repair will restore the original system files of your computer with your windows installation CD. It will not affect the installed applications and your files when doing a windows repair.

Answered By 0 points N/A #106879

Keyboard producing different keys from the ones typed

qa-featured

This problem occurs when your keyboard is filled with some type of fluid like water or any liquid. A virus program can also in fact your keys. So check both of them and you will find the right one. If it is infected by some liquid  then make it clean. In case of virus effect start your PC in safe mode and try to make it virus free.

Also see that the keyboard that is with in windows is working properly or not if that keyboard is working properly then the fault is in your keyboard or the keyboard port. So check them both.

In case of virus make a full scan of antivirus which will make you keyboard error free. Or you can reinstall the windows again if the problem remains.

But I hope if you boot your window in safe mode this problem will be removed. I hope your problem is solved by these steps.

Login/Register to Answer

Related Questions