Invalid Config Path Android Studio installation

Asked By 50 points N/A Posted on -
qa-featured

Hello Troubleshooter,

Android Studio installation was successful without any error. The problem triggered when I try to launch the application I ended up with an error message. After a search, I even updated the IDE but no result still I get the following error message. Please help me to resolve the error. Thank you.

Invalid Config Path

Config path “C:Program Files (x86)Androidandroid-studioconfig” is invalid.

If you have modified the ‘idea.config.path’ property please make sure it is correct, otherwise please re-install the IDE.

OK

SHARE
Answered By 70 points N/A #188229

Invalid Config Path Android Studio installation

qa-featured

Hello,

This is such an error that is appearing because of permission. The folder directed was inside Windows directory (C drive) that Windows won’t let to access without administrator. Right-click on Android Studio and select “Run as administrator”.

Also try changing a line inside “C:Program Files (x86)Androidandroid-studiobinidea.properties”. Edit it with Notepad.

You’ll see like this:

#———————————————————————

# Uncomment this option if you want to customize path to IDE config folder. Make sure you're using forward slashes

#———————————————————————

#idea.config.path=${user.home}/.AndroidStudioPreview/config

 

#———————————————————————

# Uncomment this option if you want to customize path to IDE system folder. Make sure you're using forward slashes

#———————————————————————

#idea.system.path=${user.home}/.AndroidStudioPreview/system

….etc

 

Remove # in front of the line before last.

#———————————————————————

# Uncomment this option if you want to customize path to IDE config folder. Make sure you're using forward slashes

#———————————————————————

idea.config.path=${user.home}/.AndroidStudioPreview/config

….etc

 

Now launch Android Studio. It should work fine.

Login/Register to Answer

Related Questions