Internet Explorer 8 does not display pages correctly

Asked By 110 points N/A Posted on -
qa-featured

I am presently testing web pages developed by my company. My task was to check the compatibility of our present website with the new version of Internet Explorer 8.

We use a lot of Google gadgets such as Charts, Graphs and Gauges. The website pages works fine when viewed in Internet Explorer 7. But when i checked the pages with Internet Explorer 8, the gadgets does not show up.

I heard that certain webpages that were working correctly does not seem to show correctly in IE 8. The funny thing is when i checked the sample pages for the charts, graphs and gauges given by Google in their online documentation via Internet Explorer 8, the gadgets works fine!

Does anyone know the reason? Please help!

SHARE
Best Answer by TechnoHat
Answered By 0 points N/A #89348

Internet Explorer 8 does not display pages correctly

qa-featured

 

Did you try comparing the page source (HTML) with that of the sample pages in Google? Take a look especially at the header where the DOCTYPE declaration is. It starts as follows:
 
<!DOCTYPE html PUBLIC 
 
To give you an understanding, the DOCTYPE declaration tells IE 8 how to interpret the document as well as to allow special settings. These settings effects the styling of the page. This line should be the very first before the HTML tag itself.
 
You can view the HTML by right clicking the page and selecting the "view source" option. You will see the HTML code of the page. It.
Answered By 0 points N/A #89349

Internet Explorer 8 does not display pages correctly

qa-featured

Sharon, you may want look if "cookies" are blocked in IE 8. Cookies are small piece of code that websites leave on each computer.

In order for the gadgets to work, the Google code downloads the required libraries from the Internet. Internet Explorer 8 blocks code that attempts to download java script files that are not on the same domain.

In order to find out if cookies are blocked, see if you can see an "eye" icon on the status bar with a red color mark on it. this usually indicates cookies were blocked. you need to double click it and un-block the cookies.

Answered By 110 points N/A #89350

Internet Explorer 8 does not display pages correctly

qa-featured

Hi Experts!

I compared the doctype declaration from Google with the declaration on the website pages. They are both identical! This is getting really weird.

I then checked if cookies were blocked as advised.

Surprisingly, yes I can see a red mark over the "eye" on the status bar! When I double clicked the icon it shows that it was attempting to download a script from Google!

Any idea as to how to “automatically” make internet explorer allow cookies? Or is there an alternative that I could do? Apart from that, even if I allow cookies, still the Gauge does not display.

HELP.

Best Answer
Best Answer
Answered By 0 points N/A #89352

Internet Explorer 8 does not display pages correctly

qa-featured

Normally Internet Explorer blocks cookies from other domains UNLESS the protocol used in the link is HTTPS. HTTPS stands for the Secure version of the Hypertext Protocol. This requires an SSL certificate to be installed on the target server.

If the download of the script is via the HTTPS protocol, then the "cookie" blocker is not triggered. Internet Explorer blocks download of script files AND cookies from different domains on un-encrypted channels.

Did you try viewing the pages in "Compatibility" mode?

Compatibility mode is a special mode that will emulate Internet Explorer 7 within Internet Explorer 8. It is under the "View" menu of IE. Turn it on and check if you can see the pages correctly?

Answered By 110 points N/A #89354

Internet Explorer 8 does not display pages correctly

qa-featured

Hi TechnoHat,

I used the compatibility view and the page loads up fine. I can see the Google gadgets (Charts, Gauges, Graphs) perfectly on the pages.

Out of curiosity, i have another question is there anyway that i can automate this setting? This is because i don't want the users to be manually selecting this option.

I searched the internet but could not fine a solution. Please guide me in the right direction.

Answered By 0 points N/A #89356

Internet Explorer 8 does not display pages correctly

qa-featured

 

Sharon,
 
I am glad to be of help!. Just put the following "magic" line immediately after the "<head>" tag and your problem is solved. Please note it must be the very first tag before anything else.
 
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
 
Let me know if you face any further problems.
Answered By 110 points N/A #89357

Internet Explorer 8 does not display pages correctly

qa-featured

Fantastic! Pages are looking great! I sent it to the development team and the are conveying their thanks to you! Thank you again for taking your time to solve my problem!

Login/Register to Answer

Related Questions