Installation Issues of Enterprise Library [3.1]

Asked By 0 points N/A Posted on -
qa-featured

Hi,

I have an old computer system and I have decided to use it for testing purposes for the installation of [WCSF] Web Client Software Factory. This software needs Library 3.1 [enterprise], when I run the installer I faced a problem. I want to share with all of you for getting a remedy, please.

First of all, it is to inform you that I have Win XP as the operating system on that machine as well as Automation Extension [GAX] and Guidance Automation Tool Kit for 2008 [VS].

Please see the error message below, I faced while I was installing Library 3.1 [Enterprise].

installer information

Installer Information

Unable to get installer types in the D:PublicAssembliesMicrosoft.Practices.EnterpriseLibrary.BlockFactoryInstaller.dll assembly. –> Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

I am trying to find that what is wrong in that, anyone please help me.

Thanks,

SHARE
Answered By 0 points N/A #170597

Installation Issues of Enterprise Library [3.1]

qa-featured

Hi there AlexanderGRogers,

Looks like the software you're trying to install have some problems with paths or OS compatibility.

First of all, check the location mentioned in the error (D:PublicAssembliesMicrosoft.Practices.EnterpriseLibrary.BlockFactoryInstaller.dll assembly) just to see that the folder exists. If not, create it manually.

After you're sure that folder is there and there is no corrupted files in it, perform a simply system search looking for Microsoft.Practices.. files. You will most likely find them all in another folder with similar but slightly different name. Copy them all and paste them to the folder D:PublicAssemblies.

Hope this helped,
Drake Vivian

Login/Register to Answer

Related Questions