InfoPath cannot find Web server

Asked By 780 points N/A Posted on -
qa-featured

Hi,

I have a problem encountered while working using Microsoft InfoPath. I met an error message with a text "InfoPath cannot find or cannot access the Web server" Please refer below for the full text of the error message.

 

Microsoft InfoPath

InfoPath cannot find or cannot access the following Web server: http://___/sites
Make sure that the Web server name is valid, that your proxy settings are correct, and that you have the necessary permission to publish to this library.

If the server requires you to log on through the browser, log on there and select the option to remember your log on information, the try to publish again.

The error message above that I posted is so hard for me to digest since it's to broad to understand. As I followed its suggestions, like make sure web server name is valid, I did not use any proxy.

As far as my knowledge is concerned, that was all I can do. Please share some points for me to follow in solving this issue.

Thanks.

SHARE
Best Answer by chocomaltee
Answered By 0 points N/A #123632

InfoPath cannot find Web server

qa-featured

Hello,

What you can do is to publish the form template as a site content type.

Add the form template to a document library and go to the option "Allow management of content types".

To enable "Allow management of content types", do the following:

1. Go to the document library
2. Click on "Settings" and then "Form Library Settings".
3. Go to "Advanced settings".
4. Click on "Low management of content types" and
5. Click on "Yes" and "OK".

Thank you.

Best Answer
Best Answer
Answered By 0 points N/A #123633

InfoPath cannot find Web server

qa-featured

You can try this workaround first:

Make the "Allow management of content types" option enabled.  To do this:

1. Open the document library
2. Click "Settings"
3. Click "Form Library Settings"
4. Click "Advanced Settings"
5. Click "Yes" under "Allow Management of Content Type"

Once it has been enabled, publish the form template as a "site content type" then add the form template to the document library that has been enabled to "Allow management content types".

If the above doesn't work, try this other approach:

1. Open the "Site Collection Administration settings"
2. Select "Site content types" under "Galleries"
3. Click on "Form"
4. Click on "Advanced Settings". This screen will come up:

5. If the "Enter the URL of an existing document template" has a value, just clear it to look like this:

6. Create a new Form library.

Answered By 0 points N/A #123634

InfoPath cannot find Web server

qa-featured

This could be the some causes of such error.

1. This issue can occur if InfoPath 2003 cannot find the downloaded file in the Temporary Internet Files folder for the current user.

To resolve this issue, download and install Microsoft Security Bulletin MS04-38.

For more information about Microsoft Security Bulletin MS04-38, click the following article number to view the article in the Microsoft Knowledge Base: MS04-038: Cumulative Security Update for Internet Explorer.

To work around this issue, use either of the following methods:

Method 1: Use the Open command in Internet Explorer

  1. Start Internet Explorer.
  2. Click File, and then click Open.
  3. In the Open box, type the URL that you want to open, and then click OK

Method 2: Empty the Temporary Internet Files folder

  1. Start Internet Explorer.
  2. Click Tools, and then click Internet Options.
  3. Under Temporary Internet files, click Delete Files, and then click OK.
  4. Click the link to download the InfoPath 2003 form.

2. This may also occur because SharePoint Designer was blocked.

If the client had a CodePlex utility called NoSharePointDesigner installed in their non-prod environments (they hadn't migrated it to prod yet). Checking the web.config of your app, you will find an entry for NoSPD HTTP Handler that referenced the author.dll file. 

The client's SharePoint engineers had a difficult time backing out the NoSPD feature in stage because it left the web.config entry behind on all apps on the farm.

The author.dll works with Front Page Server Extensions to allow remote publishing to web sites. NoSPD works by blocking access to the author.dll file, thus preventing SharePoint Designer from connecting to and opening SharePoint sites.Unfortunately, this also prevents InfoPath from connecting to and opening SharePoint sites as well.

If this doesn’t work at all contact a technical support.

Answered By 0 points N/A #123635

InfoPath cannot find Web server

qa-featured

Here are a few suggestions to solve that issue:

  1. Make sure you are the site collection administrator of your site.

  2. If you have not done this, publish the form template as a site content type.

    Then add the form template to a document library and make Allow management of content types option enabled.

  3. If still not solved, there might be peculiar settings which were set. 

    There is one I know that could cause the error due to wrong setting.

  • Go to the Site Collection Administration settings.
  • Under the Galleries, select the Site content types.
  • Click Form and then click Advanced Settings.
  • If there is a value in Enter the URL of an existing document template, remove it.
  • Then create a new Form library again.

Hope any of these helps.

Login/Register to Answer

Related Questions