Cannot end explorer.exe Process after copying file

Asked By 200 points N/A Posted on -
qa-featured

Hi,

I was copying files(it was about 900 MB in total) to my USB flash drive and as I watched the copying in progress bar, it stopped halfway. I waited for almost 30 minutes and still no progress. So clicked cancel, but it asks if I allow to end and restart explorer. exe, so I did. After that my computer became so slow. I checked in the task manager and shocked to see explorer. exe uses about 50% of CPU. I assume that's the cause, so I tried to end process . I click end process, and confirm, but nothing happens. Explorer. exe is still there eating up CPU resources.

How can I get around this? I don't want to turn my computer without shutting down properly.

Thanks.

SHARE
Best Answer by Frank Mkl
Best Answer
Best Answer
Answered By 0 points N/A #129015

Cannot end explorer.exe Process after copying file

qa-featured

Hi Theodorefrost,

Recently, I have seen your problem. After using many days, naturally your computer gets slow. This is not always for the virus related problem. There are some other reasons. Temporary files can slow down your computer. Please clean those files.

To do this:

  • Click on start menu. Go to All Program>Accessories>System Tools>Disk Clean Up.
  • Clean up window will be opened. Select the drive that you want to clean. Hit enter. A list of temporary and other unnecessary file will be shown.
  • Delete all files.
  • Again click on start menu; go to All ProgramAccessoriesSystem ToolsDisk Defragment
  • Select a drive and Defragment it. You should apply defragment to all drives. You also should check your disks 1 time in a month regularly in the disk check option to recover bad sectors.
  • Hope your computer will show better performance than previous.

Thank you

Answered By 0 points N/A #129016

Cannot end explorer.exe Process after copying file

qa-featured

Unfortunately there is no prefect fix for the problem you are facing but there are ways to reduce the probability of such.

1.       Firstly make sure that your Antivirus/ Anti-Malware program is amongst those that do not consume a lot of process power.

2.       Make sure that the Indexing for search for your user account is turned off.

  • Click on Start -> Control Panel -> System and Maintenance -> Administrative Tools-> Services.  Alternatively, just type “Services” (without quotes) in Search box from your Start Menu.
  • If User Account Control asks for permission, click on Continue.
  • Locate the service named “Windows Search”. Right click on it and select Properties on contextual menu.
  • Click on Stop button to stop the indexing service immediately.
  • On the Startup Type dropdown box, select Disabled.
  • Click on OK button.

This will hopefully eliminate most of your problems.

Good Luck!

Login/Register to Answer

Related Questions