How to Google.com etc are not translated by firefox?

Asked By 210 points N/A Posted on -
qa-featured

It sucks when I open Amazon.com. It redirects into other languages, as well as other important sites. Google.com redirects to Google.com. id and wikipages redirects to Indonesia. I live in Indonesia.  I just want a way to get the exact pages I want to view without stupid translations etc.

SHARE
Best Answer by Sandra Cromwel
Best Answer
Best Answer
Answered By 0 points N/A #82619

How to Google.com etc are not translated by firefox?

qa-featured

You can set as your homepage this Google web address that will always take you to Google.com without redirecting your: https://www.google.com/?gws_rd=cr. You should also enable cookies in your web browser.

Answered By 567090 points N/A #82620

How to Google.com etc are not translated by firefox?

qa-featured

When installing Mozilla Firefox, it automatically sets the default search engine to Google. When you open Mozilla Firefox you will be presented with a blank page with Google search bar in the middle. This are all done and set automatically during the installation and this is the default setting of the web browser.

If you search something using Google, the page will automatically detect your language based on your current IP address that will detect the country of origin and will set the page in your own language. Try uninstalling Mozilla Firefox and then install it back to fix any corrupted files in the installation and to restore its settings back to default.

You may also try upgrading your current version of Mozilla to Mozilla Firefox 11.0, the latest release. You can download it at http://www.mozilla.org/en-US/firefox/fx/.

Login/Register to Answer

Related Questions