How to fix unarc.dll or Isdone.dll errors?

Asked By 20 points N/A Posted on -
qa-featured

Whenever I’m downloading any archive from the Internet and trying to unpack it, or install it, for example a game or so, with the help of installation program I am facing Inno setup errors like the “unarc.dll” and “Isdone.dll”. I want to know the reason and solution to it. Please help.

ISDONE.dll

An error occurred when unpacking!

Unarc.dll returned an error code: -1

ERROR: archive data corrupted (decompression fails).

SHARE
Answered By 0 points N/A #98634

How to fix unarc.dll or Isdone.dll errors?

qa-featured

Unarc.dll or Isdone.dll errors are quite common amongst users. They may occur when your archive data is corrupt or due to installation of Resident Evil, Assassin’s Creed, Crysis Warhead and such games.

Firstly, try disabling your antivirus and run the program again. If it works, you may go to the bottom of the page to use the share buttons for enabling again. If that too doesn’t work, then maybe the path to the file that won’t run has non-latin characters in it. You can try moving your file to another location/drive. These steps may seem strange, but you should try them if you really want to fix the error. Move the file from your erroneous computer to another PC without downloading it from the same internet source on the Internet because, your PC might be having RAM issues.

If the other PC still shows the same error try unpacking or installing it. If none of the troubleshooting method worked, then you should look into the lines of code in the source of the file. If your RAM happens to be the cause of the unarc.dll error, then you may remove your memory modules one by one and after reinstalling, try testing the program again.

Answered By 566970 points N/A #304606

How to fix unarc.dll or Isdone.dll errors?

qa-featured

That error has nothing to do with your file archiver because the file you are unpacking or extracting is corrupt as indicated in the error message. If you have doubt about the program you are using to unpack compressed files, try using 7-Zip file archiver. It is a file archiver or file compressor similar to WinRAR and WinZip.

The only difference is that the two are commercial software while 7-Zip is not. 7-Zip is an open source file archiver that any user can download and use for free. It supports unpacking of compressed files created with WinRAR and WinZip. It can also compress files using the ZIP format (*.zip) which is the default format for WinZip but not RAR format (*.rar) for WinRAR.

Once 7-Zip is installed, try downloading the file again and see if it can be unpacked by 7-Zip. If the error turns out the same, try downloading the file from a different website.

Login/Register to Answer

Related Questions