How to detect tasks loaded in Citrix session?

Asked By 0 points N/A Posted on -
qa-featured

I need an output that will produce graphs using Excel data stored in a database in Lotus Notes. Once the graphics are composed in Excel, copied and pasted into a rich text field in Lotus Notes which is displayed to the user so that the user will not look everything in the Excel.

But if Excel is already loaded by the user when Lotus Script starts depending on the amount of data in the graph, there is not enough memory available to copy and paste the graphic into Lotus Notes. To address this, I wrote a code that is downloaded from Excel before executing the graphing process that works well.

However, the closing method was completing the Excel session without  prompting the user to confirm the saving of any calculation or open books resulting in potential data loss. So I created a new  function now that will  check for stand and ask the user to close Excel manually before proceeding with the graphical representation.

Now this works fine on a PC or laptop when the user has a local version of Lotus Notes, but not when the user logs on to Lotus Notes through Citrix account. Excel is always in Citrix reporting as active although not in the Windows Task Manager. Do you know how to detect all tasks loaded on a Citrix session? So you can correctly identify whether Excel is loaded or not.

Thanks.

SHARE
Answered By 0 points N/A #91133

How to detect tasks loaded in Citrix session?

qa-featured

The problem could be arising because of the settings you have configured in the lotus notes application. You may have specified that lotus notes loads the excel program automatically, and therefore it should be in the task manager. There is no way that the excel program will execute without being in the task manager. You might just be using the wrong procedure to locate the application in the windows task manager. Try the following:

  • Press Ctrl + Alt + Del on your computer keyboard.
  • Click on Task Manager to open it.
  • In the task manager window, click on the processes tab, and then look for the excel program from the list.
  • End that process.

That you will not have excel executing in lotus notes.

Regards
Thompson Locker

Login/Register to Answer

Related Questions