How to change Open with Settings for a EXE File.

Asked By 10 points N/A Posted on -
qa-featured

I am network administrator of a 50 PCs computer Network. One Operator in my network Selected open with vlc player for Exe Files now all my Exe files opens with vlc player. I have very important Data on my PC and I want to short out this Problem without reinstalling my PC. My Window Stop workings please provide me Solution for this Problem and tell me how I can set default Open with Settings for a EXE File. Regedit is not opening at this time.

SHARE
Best Answer by Riley weaver
Answered By 0 points N/A #188992

How to change Open with Settings for a EXE File.

qa-featured

 

Hello Mike Atherten,

Don’t worry you will not have to reinstall your computer, it is very easy to go back to default settings, just follow the instructions below:

–      Press Windows+R Buttons

–      Type cdwindows and hit enter

–      Now enter regedit to open Registry Editor

–      Now go to this key HKEY_CLASSES_ROOT.exe

–      On the right side, change default key to exefile

–      Now go to HKEY_CLASSES_ROOTexefileshellopencommand

–      On the right side, change default key to "%1" %*

–      That’s it, restart your computer.

Best Answer
Best Answer
Answered By 0 points N/A #188993

How to change Open with Settings for a EXE File.

qa-featured

Hi there,

First you can do it to open your regedit. Reboot in safe mode and open cmd, write regedit and press enter. If registry editor appears then you can change the settings from here. Otherwise you have to enable the registry editor and then you can make the EXE files to open in default format.

Now to enable the registry editor open a notepad and write the below command

reg add "HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem" /t Reg_dword /v DisableRegistryTools /f /d 0

Now save it with this name “EnableRegistry.bat”, this means the file’s extension will be .bat. Now reboot the windows and click on the file. Then, regedit should open from run. Now in registry editor follow the key as below:

HKEY_CLASSES_ROOT.exe
In right-side pane, change value of Default key to exefile

Then:

HKEY_CLASSES_ROOTexefileshellopencommand
In right-side pane, change value of Default key to:
"%1" %*

Now restart the computer. The problem should be solved.

Also try Microsoft fix it. This can help you directly without so much work.  

Best regards,

Riley Weaver.

Login/Register to Answer

Related Questions