How can I get an access permission for my secondary hard drive?

Asked By 340 points N/A Posted on -
qa-featured

I bought a new secondary hard drive but every time I connect it to my PC to access my files and folders, an error box is appearing that deals with ownership or permission to access this.

There are no available files or folders showing on my screen, only this error:

You don't currently have permission to access this folder

Click Continue to permanently get access to this folder.

If I clicked on Continue, a box with the drive letter will flash but there is nothing in the box and the same error box will appear after that. If I clicked on Cancel, all the box will disappear I am sure that before buying my secondary hard drive, they already formatted this to NTFS. I already logged on as the administrator to take full control of my system and even made another user account with admin privileges but nothing happens so far.  I am using Windows Vista Service Pack 2.

Does anyone know how to gain full access to my hard disk drive? And how to correctly connect the IDE Data Cable and the SATA Data Cable? This maybe because of a wrong connection on these cables. I need detailed instructions.

Thank you.

SHARE
Best Answer by Annies
Best Answer
Best Answer
Answered By 0 points N/A #112452

How can I get an access permission for my secondary hard drive?

qa-featured

Hi there,

In order to fix the issue you are having with your drive, here's something you can do to get ownership of the drive and get full access to it. Sometimes, even if you are the Administrator, you still need to set this setting to get full control of a drive:

  1. Right click the folder/drive you want to access, go to Properties then Security tab

  2. Click on Advanced then the Owner tab then click the Edit button.

  3. Click your user name, the user name you are currently logged in to, and check the box Owner of underlying containers and object.

  4. Click OK to exit.

  5. Now right click the folder/drive again then go to Security then click Edit.

  6. Click on Add then type your user name in the text box. And click on Check name.

  7. Back to the Security window, select your user name and under permissions check Full Control.

  8. Click OK.

Answered By 0 points N/A #112453

How can I get an access permission for my secondary hard drive?

qa-featured

Hi Porter,

For resolving this issue, do the following steps:

You need to turn off Simple File Sharing and then take the ownership of the folder.

Turn off Simple File Sharing:
Click Start menu and then click My Computer option On the Tools menu, click out the Folder Options scroll down to the View tab and then by clicking it. Upon opening below the Advanced Settings option, click to clear the option Use simple file sharing (Recommended) given check box, and then click OK.

Right click on the folder for which you want to take ownership and then go into the Properties.
Clicking the Security tab, and click ok on the Security message, if it appears. Further Click Advanced and then click Owner tab. In the Names list, click your user name as Administrator if you are logged in as Administrator or click the Administrators group option.

Hope this will work for you.

Thanks!

Answered By 340 points N/A #112454

How can I get an access permission for my secondary hard drive?

qa-featured

I used the above solutions and can now access my new hard drive.

Thanks for the help Expert!

Login/Register to Answer

Related Questions