Having problems using my USB ports

Asked By 10 points N/A Posted on -
qa-featured

Hi, I am having problems using my USB ports. None of them recognizes any of the devices I insert. However, the device manager shows that the devices I insert draw power and work properly. What could be the problem here and how do I solve it? Thanks a lot.

SHARE
Best Answer by OliviaLohan
Answered By 0 points N/A #85379

Having problems using my USB ports

qa-featured

Wachindra,

I had this same problem a month ago, later I found out that it is problem with viruses. Viruses attacked my PC even though I had an antivirus, then I re-installed my Windows. You should first install an antivirus and scan your whole PC, if it doesn't work, then you will have to re-install Windows, or maybe you should try to update all the drivers with driver genius.

Thanks.

Best Answer
Best Answer
Answered By 0 points N/A #85380

Having problems using my USB ports

qa-featured

Hi Wachindra,

In order to fix the issue you are facing regarding the USB Devices not being recognized,

 

 

Please follow the given solutions to ensure that the error is fixed,

* Uninstall the drivers for your devices and re-install them.

* Use System Restore for Windows to Restore your computer to an earlier time (preferably to when USB devices were detected normally) in case this error is caused by some installation conflicting with the USB drivers.

* If they still don't work, go to Device Manager, Uninstall all the USB Port/Hubs under USB Controllers listed in the Device Manager, and restart your computer (The USB Devices will be re-installed automatically on a fresh reboot of your PC). After your computer restarts, download the chipset driver installation utility from here:

https://downloadcenter.intel.com/confirm.aspx

httpDown:

http://downloadmirror.intel.com/16023/a08/infinst_autol.exe&agr=&ProductID=&DwnldId=16023&strOSs=&OSFullName=&lang=eng

and restart the computer.

The Devices should work fine after you apply these steps. In case it still does not work.

* Shut Down your computer and unplug it from the power socket/power supply. Wait for about 1 minute and then plug it back in. This should solve your problem as a fail safe.

Hope This Helps.

Login/Register to Answer

Related Questions