No of visitors who read this post: 826
Category: Anti-Virus
Type: Question
Author: Aileenriggs
No votes yet

I installed Avast for Linux version (in Ubuntu 9.10) and got through without any problem. Avast was then successfully showed in the Applications menu.

But, when I tried to run Avast, I received this error message:

Avast! Error

An error occurred in avast! engine: Invalid argument.

Please help me solve this.

Thanks in advance.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 47607

Hope this could work.

Open up terminal and type the following:

Code:

cd / etc /init.d/

sudo gedit rcS

Type the password and gedit will open the file.

Add the following comment below the line starting with #

systcl -wkernel.shmmax=100000000

For example,

# rcs

#

# Call all S??* scripts in / etc/ rcS .d / in numerical/alphabetical order

#

sysctl -w kernel.shmmax=100000000

Then save the file, open in gedit and close the window.

Restart computer and log into your user account.

Fire up terminal again.

Code

Avastgui

 Better luck !!!

divya...

# Comment Id: 47611

Hello Aileenriggs,

Let me try to solve your problem. Run 'sudo sysctl kernel.shmmax' and note the value. The default should be something like 33554432. Now double that initial value with 'sysctl -w kernel.shmmax=$[33554432*2]' and try running your avast antivirus once again.

If it works (worked for me) then the issue will be solved. If it doesn't work try multiplying the initial value until you can run your avast antivirus. If you want to make the value stick on reboot add it to /etc/sysctl.conf or any other local init script that gets run on boot. I hope this solution will help you.

Regards.