Google layers Plugin – Looking for solution

Asked By 20 points N/A Posted on -
qa-featured

Hi friends,

I have recently started using windows XP operating system. I have currently installed Quantum GIS 1.7.4 at work and I have trouble to run Google layers plug-in. I have installed it from the OsGeo installer. In fact, when I start QGIS 1.7.4 the following message appears and I cannot use Google layers plug-in:

Couldn't load plugin GoogleLayers due an error when calling its initGui() method

Python error

Couldn't load plugin GoogleLayers due an error when calling its initGui() method

On initializing QGIS I receive the above mentioned python error on my screen and the QGIS crashes completely. I have tried to resolve the issue by installing the latest version of QGIS which is master 1.9.90 but still the same error keeps on coming again and again.

Kindly do let me know if I am missing anything. Any help regarding this issue will be highly appreciated.

Looking forward to your replies.

Regards.

Jill.

SHARE
Answered By 0 points N/A #141095

Google layers Plugin – Looking for solution

qa-featured

Please follow this instruction to fix the error. I found this one to some forum and it works for me.

1.    Copy matplotlibrc file from C:…OSGeo4Wappspython25libsite-packagesmatplotlibmpl-data to this path                 C:Documents and Settings user name.matplotlib
(note that you enter your computer username from the word “username” inside the path).


2.    Open the above file then edit the number 31 line from this backend : TkAgg to this one backend : Qt4Agg
Then save the file.


3.    After that restart QGIS and install matplotlib-dependant plugin.

Just follow the instruction above and it should work. I also tested Roubeyrie’s contour plugin and it generates contours from the shapefile points!

Login/Register to Answer

Related Questions