Glassfish V3 Installation Error – JDK

Asked By 10 points N/A Posted on -
qa-featured

Hi guys,

I am trying to install an open-source application server GlassFish v3 on my system since the last two days but I could not succeed. Each time I start the installation, an error window pops up on my screen. The screenshot of the error is attached below:

Starting GlassFish Server Open Source Edition 3 (Java EE 6) 5 at localhost' has encountered a problem.

Problem Occurred

'Starting GlassFishServer Open Source Edition 3 (Java EE

6) 5 at localhost' has encountered a problem.

GlassFishv3requires a JDK1.6 and not a JRE. Please

add/select the correct JDK in the Server properties

'Runtime Environment' section.

OK << Details

GlassFishv3requires a JDK1.6 and not a JRE. Please add/select

the correct JDK in the Server properties 'Runtime Environment'

section.

As you can see, it asks me to select a java development kit (JDK) in the server properties and in the runtime environment section also but I cannot see it anywhere.

Has anyone else encountered this problem before? If yes, please do let me know.

Looking forward to your replies.

Regards.

Jerry

SHARE
Answered By 0 points N/A #141265

Glassfish V3 Installation Error – JDK

qa-featured

In order to install the GlassFish V3 you should first install the prerequisite. Here the error is coming because the Java version what you have in your system is lower version which is Java 1.5. Install the latest Java edition or use the Java 1.6. Once you have installed the Java 1.6 set the environment variable for java to recognize its library path and all. Then you start installing the GlassFish. I think this will resolve your problem. Please let me know if it occurs again after doing the above process.

Most likely it may not appear as the error straight away states it didn't fine java 6 in your system. If already java 6 is installed in your system just check the environment variable and try to install again.

Login/Register to Answer

Related Questions