Ftp user (any) can’t change directory /home/any

Asked By 10 points N/A Posted on -
qa-featured

I am installing and configuring vsftpd but the user can not login FTP server. Show error message : 500 oops can't change directory /home/root pleases solved this issue Alamgir.

SHARE
Best Answer by Paul Nixon
Best Answer
Best Answer
Answered By 0 points N/A #88368

Ftp user (any) can’t change directory /home/any

qa-featured

su-

getsebool –a |grep FTP

setsebool –p ftp_home_dir on

getsebool –a |grep FTP

Result:
[[email protected] ~] # getsebool -a | grep FTP
allow_ftpd_anon_write –> on
allow_ftpd_full_access –> off
allow_ftpd_use_cifs –> off
allow_ftpd_use_nfs –> off
ftp_home_dir –> on
httpd_enable_ftp_server –> off
[[email protected] ~] #

Answered By 0 points N/A #88370

Ftp user (any) can’t change directory /home/any

qa-featured

Hello Alamgir,

There are lots of solutions over the internet for your problem. But there are some things that you need to check first.

1. User and group permission for the account match, then make sure that readable and executable to the home directory for that account is defined.

Below are the actions that you need to do to solve this issue.

[root@bongets vsftpd] # getenforce

[root@bongets vsftpd] # getsebool -a | grep FTP

allow_ftpd_anon_write –> off
allow_ftpd_full_access –> off
allow_ftpd_use_cifs –> off
allow_ftpd_use_nfs –> off
allow_tftp_anon_write –> off
ftp_home_dir –> on (change that to on in your case this option is off)
ftpd_disable_trans –> off
ftpd_is_daemon –> on
httpd_enable_ftp_server –> off
tftpd_disable_trans –> off
[root@bongets vsftpd] # setseboll -P ftp_home_dir on

This is all that you need to do.

Thanks.

Login/Register to Answer

Related Questions