No of visitors who read this post: 609
Category: Misc Software
Type: Question
No votes yet

This is a new installation of freestyle on Windows 7 (HP Pavilion p6531). The program seems to be ok but each time when I start it then an error message appears which is:

Error:

Heidi Module Load Error

The configured Heidi driver cannot be loaded. Switching to default software driver.        
 

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 57441

Hi there,

There are various problems regarding AutoCad Freestyle, one of them is the Heidi driver error. This particular error takes in many forms like “Heidi Module load error” or “The configured Heidi Driver cannot be loaded-switching to default software driver.

The proper solution for this particular problem is to do the following, and hoping that it will solve your problem as this has been very effective in eradicating this error.

The solution is to disable Hardware Acceleration by starting Freestyle with the /nohardware switch, to do this you have to follow these steps.

  • Go to the properties of the freestyle application by right clicking on the icon on your desktop
  • The default target should be "C:\Program Files\Autodesk\AutoCAD Freestyle\acadfs.exe"
  • Add a space after .exe” and write the /nohardware switch, it should look like this.
    "C:\Program Files\Autodesk\AutoCAD Freestyle\acadfs.exe" /nohardware
  • Apply then Ok , afterwards re-launch Freestyle

Hope it turns out well for you