Firewall switching to disable mode everytime

Asked By 0 points N/A Posted on -
qa-featured

Everytime i start my computer my firewall is set to disable mode. Always I have manually enable it. How can I fix this?

SHARE
Best Answer by Sharath Reddy
Answered By 0 points N/A #89224

Firewall switching to disable mode everytime

qa-featured

Hello Genelyn,

First of all, do you have an antivirus software?  Like Norton? If you do then you should know that software like these have their own firewall. In order to avoid conflicts they usually manage the firewall themselves. If that is you problem then there is nothing to worry about.

 Now, if that’s not the case then you probably have Trojans or other type of malware. If so run your computer in safe mode and run anti malware or antivirus programs. Hope that solves your problem.

Best Answer
Best Answer
Answered By 556365 points N/A #89226

Firewall switching to disable mode everytime

qa-featured

This is odd. The only reason why Windows Firewall is always turned off is when you are using Norton Internet Security because the antivirus already has a built-in Smart Firewall that is far greater than Windows Firewall. If you are using NIS then this is normal but if not then there is something not normal happening in your computer.

Update your antivirus then run a full system scan on your entire hard drive. If you are not using NIS or other third-party firewall application then there is something that automatically turns off your Windows Firewall. If the scan returned negative then it is probably not a virus. Try turning on the Windows Firewall again.

Click Start, Control Panel, Network and Internet Connections, Windows Firewall. Select “On (recommended)” then click OK. Make sure you click OK to properly apply it and not the X button. After activating it, close all windows then go back to the Windows Firewall again then see if it’s still activated. If there’s no change, restart your computer and then check the Windows Firewall again.

No change should be expected. If it was disabled again, check if there is a code inserted in the autoexec.nt formerly autoexec.bat. Open Windows Explorer then navigate to “C:WINDOWSsystem32”. Find “AUTOEXEC.NT” and then open it with notepad. Check if the command “netsh firewall set opmode disable” is not listed there.

If you can’t find it there and still Windows Firewall is always turned off, you can add and configure it from this file. If “AUTOEXEC.NT” is already open, add this command at the end of the file: “netsh firewall set opmode enable”. Save it afterwards then restart your computer. This time, each time you start your computer Windows Firewall will always be turned on. See image.

Login/Register to Answer

Related Questions