Firefox – Problem with website link

Asked By 0 points N/A Posted on -
qa-featured

I am using Mozilla Firefox as my web browser. The problem is that when I click on any website the links don’t open. Some links do open but some don’t open at all. Initially it was working well but suddenly the problems come.

I don’t know what the problem is. It may be because of updating Firefox. The IE is working without any problems as it opens all links. If anybody knows the solution to my problem, please help me. I will be thankful for all your help.

SHARE
Best Answer by Kirmana_Roy
Answered By 0 points N/A #99968

Firefox – Problem with website link

qa-featured

You didn’t mention which version of Mozilla Firefox you installed. If it is old then try to upgrade your version. This is your primary work to fix this problem. If it doesn’t work then you can follow either of the steps below to solve this problem:

  • Reboot your PC and then start your browser.
  • If you are using a dial-up network then check your auto connect option.
  • If you find your problem remaining then it is nothing but a confliction with any of the software on your PC. Try to find it and remove it from your system.
  • Keep your computer cache, browser clean and always remove temporary files from your computer. Your problem will be solved.
Best Answer
Best Answer
Answered By 0 points N/A #99970

Firefox – Problem with website link

qa-featured

Hello Kyler,

There are several reasons why Mozilla Firefox isn't loading a website. But based from your situation, there are only two possible root causes for this problem:

  1. It cannot open any websites but other web browser like IE does.
  2. It cannot connect to any links/websites after upgrading/updating Firefox.

 

Solutions: Web browser (Mozilla Firefox) should or may display the following after trying to open a link or website. "Server not found" or "Unable to connect" or "Error loading website" message error.

Do the following to solve the problem:

  • Check the "Up-to-date" of your Internet Security Software and remove Firefox from your list of trusted and recognized programs. Then put it back in the list again.

Sometimes the problem apply when your Internet security software were enabled during the previous version of your Mozilla and does not recognize anymore your updated version.

  • If that doesn't work try to check your Firefox connection setting if proxy setting is enabled.

Change it through Tools(Firefox button for later version)–>Options–> Advance panel –> Network tab–>under connection section select "Network" then select "No Proxy" option. Click Ok then exit on that window.

  • Disable your IPv6 setting.
  1. in the browser/location bar type this term "about:config" and press Enter.
  2. When a warning page appears. Click "I'll be careful…" to continue.
  3. In the Filter field option, type this "network.dns.disableIPv6".
  4. At the preference options, double-click "network.dns.disableIPv6".
  • Disable Prefetching DNS option.

Do no.1 and 2 on the above, then RMB(Right-Click) on the preferences option, select New, then Boolean. Type network.dns.disablePrefetch on the Enter the preference name window then click ok. When you are prompted to set a value, select True then click ok.

  • Clear History in cache.

Simple press ctrl+H to load, select all then press del to delete.

  • Lastly, check your pc for malware.

Hope this helps.

Answered By 0 points N/A #99971

Firefox – Problem with website link

qa-featured

Thank you both. Specially thanks to kirmana_roy for your expert opinion. My browser is ok now. I can browse websites without any problem. Thanks techyv.

Login/Register to Answer

Related Questions