Fedora 9 unrecoverable processor error

Asked By 200 points N/A Posted on -
qa-featured

Hi all Hi all,

My operating system on my PC is Windows XP and Microsoft Virtual PC 2007. I installed Fedora 9 and when I ran the program, I got the below error message.

“Fedora 9: An unrecoverable processor error has been encountered. The virtual machine will reset now.”

Any idea what this might mean?

I tried installing Fedora 9 again. Yet this error message seems to appear. Is it the Fedora version that must be faulty? Or is my Virtual Memory playing up? How do I know for sure what the problem might be and how best do I sort this out?

When I click the reset button and run the program again. I still get this error. Should I use a newer version Fedora? Is there one existing that I can download?

Thanks.

SHARE
Best Answer by Wally_West
Answered By 0 points N/A #129179

Fedora 9 unrecoverable processor error

qa-featured

This is a known issue with Fedora 9 and Ubuntu 8.04 in Microsoft Virtual PC 2007. In this version of Linux kernel Virtual PC images need a noreplace-paravirt boot time option passed in order to properly boot in Microsoft's Virtual PC 2007.

So, here is the fix, start up your Virtual PC, press ESC key to enter the main boot screen. Press Tab to Edit the options. At the end of the boot parameters, add noreplace-paravirt and press enter.

This will solve the issue and boot up the Fedora 9 kernel well. You can find more information about this at this link.

 

Best Answer
Best Answer
Answered By 0 points N/A #129180

Fedora 9 unrecoverable processor error

qa-featured
  • Microsoft Virtual PC 2007 has problems with Fedora  and other Linux distros as guest operating system.
  • During installation:
  • While on the Welcome to Fedora 9! main boot screen, press [Tab] to let you edit the boot options.  At the end of the boot parameters, add  "noreplace-paravirt" and press Enter.  Boot up will begin.
Welcome to Fedora 9! main boot screen
  • How were you able to install Fedora 9?
  • After installation of Fedora 9:
  • After a reboot, press any key and then press "a".  Add "noreplace-paravirt" and press ENTER to continue booting.  Your PC should now boot up.
kernel /vmlinuz-2.6.25.3-18.fc9.i686 ro root=dev/VolGroup00/LogVol00 rhgb quiet

Permanent fix:

  • To make the fix permanent, you have to edit /etc/grub.conf file.  Append "noreplace-paravirt" to the end of this: kernel /vmlinuz-2.6.25.3-18.fc9.i686 ro root=dev/VolGroup00/LogVol00 rhgb quiet

Login/Register to Answer

Related Questions