Fatal Error: Steam does not run in VirtualBox with 3D acceleration

Asked By 0 points N/A Posted on -
qa-featured

I am running GNOME Ubuntu 13.10 on a VirtualBox 4.3.2 host which is Windows 8.1 64-bit. I also have the guest desktop with 4.3.2 installed through a CD from the host. My problem is, I can't make the Stream run. An error is showing and I'm not sure how to fix it. Nor do I understand why it occurs. I am looking for someone who can help mw with resolving this. The error I got is:

Steam – Fatal Error

Fatal Error: Steam does not run in VirtualBox with 3D acceleration enabled. Try turning off 3D acceleration.

OK

SHARE
Answered By 563000 points N/A #122716

Fatal Error: Steam does not run in VirtualBox with 3D acceleration

qa-featured

That is sometimes the limitation of running something under VirtualBox because there are times applications such as this one is restricted from running in this condition. But luckily, just like what the message says, there is still a way to make Steam run by deactivating the 3D Acceleration feature which is available and can be accessed in the Microsoft DirectX.

You need to run the DirectX Diagnostic Tool to fix this problem and disable the 3D Acceleration feature. In a computer running Microsoft Windows 8, press Windows logo + R then type without quotes “dxdiag.exe” and then hit Enter. You should see this window open. See image.

Select Display tab. In DirectX Features section, you should see Direct3D Acceleration enabled. Unfortunately, Windows 8 doesn’t allow you to disable this feature from the DirectX Diagnostic Tool. To disable it, download Microsoft DirectX Control Panel 9.0c. Once downloaded, unpack and run directx.cpl as administrator. In the DirectX Properties screen, select Direct3D tab and uncheck Allow Hardware Acceleration and then click OK. See image.

To verify, run “dxdiag.exe” again. Once verified that it is already deactivated, run Steam again. This should fix the problem.

Login/Register to Answer

Related Questions