Failure to configure database in Sharepoint 2010

Asked By 20 points N/A Posted on -
qa-featured

On trying to start the configuration wizard in SharePoint 2010, I faced the error message as follows:

Failed to create the configuration database.  An exception of type System. InvalidOperationException was thrown. Additional exception information: This implementation is not part of the windows platform FIPS validated cryptographic algorithms"


Products and Technologies Configuration Wizard

Configuration Failed

One or more configuration settings failed. Completed configuration settings will not be rolled back. Resolve the problem and run this configuration wizard again. The following contains detailed information about the failure:

Failed to provision the SharePoint Central Administration Web Application.

An exception of type System.InvalidOperationException was thrown, Additional exception information:

http://vaporcom-pphuvl:8000 is already routed to the Default zone of another application, Remove that mapping or use a different URL.

To diagnose the problem, review the application event log and the configuration log File located at:

C:Proaram FilesCommon FilesMicrosoft SharedWeb Server Extensions12 LOGSPSCDiagnostics 1 14 2007 14 10 16 751 1630542034log

Click Finish to close this wizard.

 

What should I do to resolve this error? Any help will be greatly appreciated.

Thanks.

SHARE
Best Answer by cathy emrald
Answered By 0 points N/A #101451

Failure to configure database in Sharepoint 2010

qa-featured

Hi,

Your SharePoint Farm must has these followings :

He is as Normal user (domain user not domain admin user)
This user Belong to the following SQL Roles
   Public

   Securityadmin
   Dbcreator
Belong to Local administrators group of SharePoint servers
Belong to the following local security groups:

  • IS_IUSRS
  • Performance Log Users
  • Performance Monitor Users
  • WSS_ADMIN_WPG
  • WSS_RESTRICTED_WPG
  • WSS_WPG

Hope it will work.

Bugal kanon

Best Answer
Best Answer
Answered By 0 points N/A #101452

Failure to configure database in Sharepoint 2010

qa-featured

I found a workaround for this issue; please check if it will work for you. The FIPS are disabled in the local security policy but in the registry, there are two locations where it was set to enable. The following locations are:

1. HKLMSYSTEMControlSet001ControlLSAFipsAlgorithm

2. HKLMSYSTEMControlSet002ControlLSAFipsAlgorithm

3. HKLMSYSTEMCurrentControlSetControlLSAFipsAlgorithm

For the first and second locations, the following values are set to 1 which means it is enabled. Change the value of the two to 0 to disable the two. But remember to back up your data before editing your registry keys.

Login/Register to Answer

Related Questions