Failed to start compiz on Linux Fedora 12

Asked By 800 points N/A Posted on -
qa-featured

Hello friends,

I want to enable desktop effects on my personal computer and that why I am trying to  run / enable compiz, but every time it gives me the error stating

Error:

Failed to start Compiz. Reverting to previous settings.


failed to start

My operating system is Linux Fedora 12.

My xorg.conf file details are as under

# nvidia-xconfig: X configuration file generated by nvidia-xconfig

# Xorg configuration created by livna-config-display

Section "ServerLayout"

    Identifier     "Default Layout"

    Screen         "Default Screen" 0 0

    InputDevice    "Keyboard0" "CoreKeyboard"

    InputDevice    "Mouse0" "CorePointer"

EndSection

Section "Files"

    ModulePath      "/usr/lib/xorg/modules/extensions/nvidia"

    ModulePath      "/usr/lib/xorg/modules/drivers"

    ModulePath      "/usr/lib/xorg/modules"

    FontPath        "/usr/share/fonts/default/Type1"

EndSection

Section "ServerFlags"

    Option         "AIGLX" "on"

EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"

    Identifier     "Keyboard0"

    Driver         "keyboard"

    Option         "XkbLayout" "us"

    Option         "XkbModel" "pc105"

EndSection

Section "InputDevice"

    # generated from default

    Identifier     "Mouse0"

    Driver         "mouse"

    Option         "Protocol" "auto"

    Option         "Device" "/dev/input/mice"

    Option         "Emulate3Buttons" "no"

    Option         "ZAxisMapping" "4 5"

EndSection

Section "Device"

    Identifier     "Videocard0"

    Driver         "nvidia"

EndSection

Section "Screen"

    Identifier     "Default Screen"

    Device         "Videocard0"

    Option         "AddARGBGLXVisuals" "True"

    SubSection     "Display"

        Modes      "nvidia-auto-select"

    EndSubSection

EndSection

Section "Extensions"

    Option         "Composite" "Enable"

EndSection

Kindly guide me in this regard.

Thanks.

SHARE
Answered By 0 points N/A #119254

Failed to start compiz on Linux Fedora 12

qa-featured

You must install the NVIDIA driver if you want Compiz run. This is how to install it :

1. Edit this file in  /etc/grub.conf, with administrator permission. place this code at the end kernel directive :

nouveau.modeset=0 vga=0×318

2. install additional repo rpms

rpm -Uvh

Download and Installation source 1

Download and Installation source 2

3. Followed by :

yum –enablerepo=rp*g install kmod-nvidia.$(uname -m) xorg-x11-drv-nvidia-libs.i686 xorg-x11-drv-nvidia-libs.x86_64

4. If you use SELinux, Set SELinux allow_execstack on :

setsebool -P allow_execstack on

5. Finally

Reboot Your System, If Doesn't work. Try to download a latest version of your Nvidia driver

Login/Register to Answer

Related Questions