Failed to load resource DLL

Asked By 1170 points N/A Posted on -
qa-featured

Hi guys, I have a scenario here my problem is Backup Exec Server service fails to start with the error message Failed to load resource DLL OLEDB32R.DLL.

OLEDB32.DLL

Failed to load resource DLL C: Program Files|Common Files|SYSTEMOle DBOLEDB32R.DLL

I am not familiar with this error message, this is my first time to encounter such error message, please help me find ways to solved this issue, I been analyzing the error for hours now and I get stuck, I already check the file OLEDB32R.DLL it is present on my drive, I am wondering why it cant be loaded. All your suggestions are welcome and highly appreciated, thanks a lot for reading my post.

SHARE
Best Answer by Mr. gilbert
Answered By 0 points N/A #124521

Failed to load resource DLL

qa-featured

Hi to resolve this issue you need to repair MDAC… Browse to C;WINDOWSinf>>>right click on mdac.inf and select install>>>then insert CD/ Installable for Windows Service pack>>> then continue installation and reboot the Server… thank you, hope its help to solve this issue.

Regards;

jovhender

Best Answer
Best Answer
Answered By 0 points N/A #124524

Failed to load resource DLL

qa-featured

Hi

Nice to see this post here. Don’t worry it is not a big problem for your server. I am giving you different solution. Please try below. Hope your problem will solve.

First one.

  • Open your C Drive thenwindows folder theninf folder. Then inside of inf you will see mdac.inf
  • Please right click this file and select install. Before this please insert into your CD/DVD ROM Drive for windows service pack installer CD. After install these reboot your computer.

Second one

  • You need to edit your registry. Please note, before edit anything from registry please take full backup. So that if you found any problem after edit registry then you can restore it quickly.
  • Now, click run and right regedit and press enter. And then navigate below
  • HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersion
  • Here please see in the CommonFileDir string value. If you see that it is not showing below, then change it as below.
  • Change the CommonFileDir string value to C:Program FilesCommon Files

Hope you get solution

Login/Register to Answer

Related Questions