Failed to create the Java VM Reason: not enough memory.

Asked By 1170 points N/A Posted on -
qa-featured

hello, I am using jalbum to organized some pictures, while in the middle of my task, I meet an error, the error message said that JNI exception: failed to create the Java VM, the Reason is not enough memory.

 

JNI exception: failed to create the Java VM

Reason: not enough memory.

 

When I read the error message above, it said that I don't have enough memory, so I checked on my RAM that might be defective, all my RAM is running at a total of 4GB, that is why its impossible to not to have enough memory, I already restarted my computer to refresh the memory, but same thing happens, same error encountered, please share some ideas on my problem, thanks in advance.

SHARE
Best Answer by neon9
Best Answer
Best Answer
Answered By 0 points N/A #124702

Failed to create the Java VM Reason: not enough memory.

qa-featured

Hello Jovyhasle, I’ll be more than happy to assist you, but for future reference please include your Jalbum program version, java version, as well as your operating system, I have used Jalbum before never really had the problem that you're experiencing however one of my first suggestions would be to try and get the most recent version it you don’t already have it you can download it here http://jalbum.net/download/jAlbum-install.exe 

Outside of that have you try launching the program by using the jalbum.jar instead of the jalbum.exe file often times you are advised to use the .exe  for java programs simply because the .jar file might not have all the necessary instructions to execute the program properly however sometimes its the only way a java based program to work.

As a last resort you could try editing the Jalbum.ini file open your jablum.ini file and where the default memory allocation is set to  "Xmx512"  change it to "Xmx256" It might seem strange to be reducing the memory allocation, but the problem you're having is not necessarily memory related its more or less just a semantic problem. Most likely you won’t have to resort to this but in any case

Hope this helps

EDIT

Just a quick edit was doing a bit of searching and found  batch file that might also be of use.

save the following information to a batch file in the jalbum program folder, the batch file is actually doing two things its launching the .jar as well as setting the memory allocated for the program

REM  Use this start script if double-clicking on JAlbum.jar
REM  does not work
SETLOCAL
%~d0
CD %~p0
start "JAlbum" /D"%~dp0" javaw.exe -Xmx400M -jar JAlbum.jar
ENDLOCAL

 

 

Answered By 566980 points N/A #124703

Failed to create the Java VM Reason: not enough memory.

qa-featured

jAlbum works on any versions of Microsoft Windows so that means this is not a compatibility problem. Aside from Microsoft Windows, jAlbum also supports Mac OS X and Linux. For Mac, it requires Mac OS X 10.6 Snow Leopard and higher. Also, if you are not using the latest version please download the latest edition.

Download jAlbum 12.1.9. Once downloaded, uninstall your existing jAlbum then run the installer you downloaded for jAlbum 12.1.9. Start the application and then see if the memory error will appear. Also remember that Java is required when using jAlbum. If you get another error about Java virtual machine or Java VM, make sure you already have JRE.

If you haven’t installed it yet, download Java SE Runtime Environment 7u60. Select the download appropriate to your operating system. Once downloaded, install it on your computer and then try running jAlbum again. Also, don’t run other applications when using jAlbum to avoid memory error. If in case the memory error continues, you may need to allocate more memory for jAlbum.

To adjust the amount of memory allotted to jAlbum, start jAlbum then go to Tools, Open Directories, and then Program Directory. Next, exit jAlbum and then open “jalbum.ini” with Notepad. In the file, find the line that begins with “Virtual Machine Parameters=-Xms64M -Xmx800M”. Change 800 to 1200 or 1600 and then save the file.

Close Notepad and start jAlbum again. Take note, because of the fact that jAlbum is an x86 application [32-bit] you cannot set the value higher than 2000M.

Login/Register to Answer

Related Questions