Errors when updating C3 – 01

Asked By 10 points N/A Posted on -
qa-featured

I have a brand new C3-01 issued by T-Mobile. I updated its software to 5.65 from a 5.60.

After the unit was restarted, the media player and the radio will not work.

I tried to reinstall the update, but I am now getting an error when I do that – "Device not supported.

Nokia software updater does not support this model."

Please help.

Best regards.

Device is not supported

Nokia Software are Updater does not support this device model.

Check which products are supported at www.nokia.com/support.

SHARE
Answered By 566270 points N/A #154113

Errors when updating C3 – 01

qa-featured

 

That’s the bad side of being an update addict. You want your device to be very up-to-date and you will really get to this side of the consequence. Whenever a new update for the iOS or firmware is released it is always not good to update or upgrade your phone immediately. This is because most of the upgrade file still contains bugs that might possibly make your device unstable or sometimes worst to not work at all.

It’s best to check first the information about the new upgrade that is available. It’s possible that the new version is intended to be installed on a different phone model but the same phone brand. This is the part that most of the time is overlooked. Since this is the current state of your phone, it’s possible that you installed the wrong version of its firmware. You should backup first your phone then restore it to its factory settings to wipe out all previously installed systems on the device leaving it just like the first time you bought it. Just reinstall all the applications after the restoration.

Login/Register to Answer

Related Questions