Error when turning on the menu translation module

Asked By 0 points N/A Posted on -
qa-featured

Hi friends,

I am recently trying to build a Drupal commerce site for my client and he is emphasizing me to get the website in multi language. Can anyone help me fulfill the requirement of my client? When I try to able the Menu translation module, I am met with an error. The screenshot of the error is attached below:

People Modules Configuration Report Help

Configuration  Report  Help

Refreshed 22 strings for the enable modules.

The configuration options have been saved.

No update information available. Run cron or check manually.

Recoverable fatal error. Argument 3 passed to I() must be an array, null given,

called in/web/htdocs/www.___.com/home/includes/menu.inc

on line 2538 and defined in I()(line 2307 of

/web/htdocs/www.____.com/home/include/common.inc)

The Website encountered an unexpected error. Please try again later.

I took it as some conflicts made by the Taxonomy menu but unfortunately I was wrong. I tried to disable the menu translation module to get the Drupal working again but I failed as I resulted in the same error.

All other translation modules are working perfectly.

Please help me fix the problem. I'll be really obliged.

Waiting for your replies.

Kind regards,

Mary

SHARE
Answered By 0 points N/A #81262

Error when turning on the menu translation module

qa-featured

Hi Thomas,

I will recommend the following procedure to help you build a Drupal site that has multi-language support:

  • First of all you will need to go to the Drupal Internationalization module from this site, and then install it.
  • After that you will access the this directory admin/build/modules.
  • Look for the Core-Optional section and from there enable the following: Locale and Content translation.
  • Next you will go to the mulitlanguage section, known as Multilanguage – i18n, and choose "enable all". Save the changes.
  • The next step will be to get the translations for the languages you want. You can get them here. Extract the languages to Drupal's folder.
  • The following language should be added using the described procedure:

    • Access the languages page as follows: admin > settings > language.
    • And then go to admin > settings > language > add to add the languages you have extracted, and then select Configure.
    • Select Path prefix only in Language Negotiation and the save the changes.
    • English has to be set as the default language.
  • The next step will be to go to blocks, and then in the area that has been disabled select a region for the Language Switcher, and then save the changes.
  • After that you will make multilingual content for all content types as follows:

    • Select edit.
    • And the select the Enabled, with translation in the Workflow settings and then save the changes.
  • Next create the content using node > add > page, and then choose English in the Language field.
  • Save the changes and then choose a translate link, and then add a translation for the language you want.

You can check here for more details.

Regards,

Carl

Login/Register to Answer

Related Questions