Error when Adding SVN Repository on Eclipse

Asked By 7060 points N/A Posted on -
qa-featured

I have Eclipse and its plug-in which is the Subclipse that are both up to date with Debian Etch.

I am having issues when trying to add a new SourceForge SVN Repository. It seems that there is a problem with the validation.

Can someone please help me understand what the error is trying to imply?

And I’m hoping for a resolution too.

Thanks.

Error validating location "org.tigris.subversion.javahi.ClientException: svn: PROPFIND request failed on '/svnroot/surveyos' svn:SSLv3"

Keep location anyway?

Yes     No

SHARE
Best Answer by Michelle Bang
Best Answer
Best Answer
Answered By 0 points N/A #82270

Error when Adding SVN Repository on Eclipse

qa-featured
  • It seems for some validation related problem and you can try the following steps:
  • If you don’t have the Eclipse latest version please downloads the latest version of that.
  • Then check the SVN repository attached fully or not or you may try to check the linked eclipse.
  • Add this Eclipse into the SVN Repository folder under the windows subfolder into your system.
  • Then Check the URL that you were trying to connect the points where the repository file contains into the Directory folder because these all are default files. 

·         conf/  dav/  db/  format  hooks/  locks/  README.txt

  • If these fail please check your proxy server.
  • You can also check the command line of SVN to connect the repository.


For software updates there are some required packages like Subclipse, SVNKit Library, Subversion Client Adapter etc.

SVNKit Client Adapter   
SVNKit Library            
Subclipse                
Subversion Client Adapter

Answered By 0 points N/A #82271

Error when Adding SVN Repository on Eclipse

qa-featured

Try to install a client adapter with subclipse. And then ensure that there is an entry for SVN Interface in the following location:

Window>Preference>Team>SVN

or

Window>Preference>Team>SVN and then select SVNKit instead of JavaHL(JNI)

Try to check your Proxy settings and any software that might be blocking Eclipe. And check your Firewall as well.

Login/Register to Answer

Related Questions