Error on running Outlook Out-of-Office Assistant

Asked By 0 points N/A Posted on -
qa-featured

I am trying to run Outlook out-of-office assistant when I got this error from Microsoft Office Outlook stating “The connection to Microsoft Exchange is unavailable. 

The outlook must be online or connected to complete this action.” I don’t know what is causing this but as far as I remember I also got this message when configuring my computer remotely. I wanted to use all Outlooks’ features that can help me while I am away from my computer.

Can you please help me with this?

The outlook must be online or connected to complete this action
SHARE
Best Answer by Anderson Wright
Best Answer
Best Answer
Answered By 0 points N/A #124024

Error on running Outlook Out-of-Office Assistant

qa-featured

Hi There,

Most probably this is due to configuration requirement in RPC Encryption. By default, Microsoft Office Outlook does not use RPC encryption. This problem can also happen if you are using Microsoft Office Outlook 2007 and you halt the Encrypt data between Microsoft Office Outlook and Microsoft Exchange profile settings.

Manually update or create your Outlook profile with RPC encryption;

For Outlook 2003

To manually bring up to date an existing Outlook 2003 profile, it uses RPC encryption with Exchange 2010, follow the procedure:

  • Go to Control Panel, then open the Mail item.
  • Click Show Profiles.
  • Select your profile, and then click Properties.
  • Click E-mail Accounts.
  • Select View or change existing e-mail accounts, and then click Next.
  • Select the Microsoft Exchange Server account, and then click Change.
  • In the dialog box that contains your mailbox server and user name, click More Settings.
  • In the Microsoft Exchange Server dialog box, click the Security tab.
  • Click to select the Encrypt data between Microsoft Office Outlook and Microsoft Exchange Server check box, and then click OK.
NTLM Password Authentication
  • Click Next, and then click Finish.
  • Click Close, and then click OK.


To create a new Outlook 2003 profile so that it uses RPC encryption with Exchange 2010, follow these steps:

  • In the Control Panel, open the Mail item.
  • Click Add to create a new profile.
  • Enter a name for your profile, and then click OK.
  • In the E-mail Accounts dialog box, select Add a new e-mail account, and then click Next.
  • On the Server Type page in the E-mail Accounts dialog box, select Microsoft Exchange Server, and then click Next.
  • On the Exchange Server Settings page in the E-mail Accounts dialog box, enter the name of your Exchange 2010 server that has the Client Access Server role.
  • Note This server may differ from the server that hosts your mailbox.
  • Click More Settings.
  • Click OK when you receive a "The action could not be completed" error message.
  • In the Microsoft Exchange Server dialog box that contains the Check Name button, click Cancel.
  • In the Microsoft Exchange Server dialog box, click the Security tab.
  • Click to select the Encrypt data between Microsoft Office Outlook and Microsoft Exchange Server check box, and then click OK.
  • Click Next, and then click Finish.


For Outlook 2007

To manually bring up to date an existing Outlook 2007 profile so that it uses RPC encryption with Exchange 2010, follow these steps:

  • Go to Control Panel, then open the Mail item.
  • Click Show Profiles.
  • Select your profile, and then click Properties.
  • Click E-mail Accounts.
  • Select the Microsoft Exchange Server account, and then click Change.
  • In the dialog box that contains your mailbox server and user name, click More Settings.
  • In the Microsoft Exchange dialog box, click the Security tab.
  • Click to select the Encrypt data between Microsoft Office Outlook and Microsoft Exchange check box, and then click OK.
Negotiate Authentication
  • Click Next, and then click Finish.
  • Click Close, click Close, and then click OK.

Hope this helpful with your problem.

Best Regards,

A.Wright

Answered By 0 points N/A #124025

Error on running Outlook Out-of-Office Assistant

qa-featured

To resolve that problem, you will need to disable the required encryption between Outlook and Exchange as follows:

  1. On the server that is running Exchange 2010, you will need to run the following command in the Exchange Management Shell: Set-RpcClientAccess –Server Exchange_server_name –EncryptionRequired $False
     
  2. The next step will be rerunning the above command for each Exchange 2010-based server which has the Client Access Server role. You will also need to run the command on each Mailbox Server role which has a Public Folder Store. .
     
  3. The outlook clients will be updated with the setting to enable encrypted RPC communication with Exchange and thereafter you will need to re-enable the RPC encryption requirement on the Exchange 2010 servers having the Client Access Server role.

Richard Smith

Login/Register to Answer

Related Questions