Error prompts while upgrading the Sony Ericsson Xperia X10 phones

Asked By 20 points N/A Posted on -
qa-featured

Hi all,

My wireless company finally provided the Android 2.1 upgrade for its Sony Ericsson Xperia X10 phones. However, when I attempted the upgrade, it instructed me to use the Sony Ericsson PC Companion software for the upgrade, but it kept on generating this error prompt, which I have posted.

 

Sony Ericsson PC Companion
 
Installation Error
 
Unable to install or start phone software update
components.
 
                                                   Close

Most phone helper applications tend to require the computer to restart for registration when done installing drivers. So, I restarted, but I still received the same error message. I already tried to restart it under different conditions like with the phone on, and phone off, but it made no difference.

What should I do about it? Any help is appreciated.

Thanks a lot.

SHARE
Answered By 0 points N/A #132812

Error prompts while upgrading the Sony Ericsson Xperia X10 phones

qa-featured

 

Hi,

The phone companion you have does not seem to support your phone. Every version of the phone companion supports specific phone models. Only those models can be updated using the software. Try the following steps:

1. Check whether your phone is detected by the phone companion or not. If it is not detected then the version does not support your phone.

2. Go to the official website of sony ericsson and check the version you need to download for your phone.

3. Make sure you check all the compatibility details before you download the version.

4. Connect the phone to your computer and see whether it is detected by your computer or not. If it is not detected then check the phone drivers.

Hope this information helps you.

 

Login/Register to Answer

Related Questions