Error Message When Opening Docs in Flash Drive

Asked By 0 points N/A Posted on -
qa-featured

Whenever I open Microsoft Word files from my flash drive, the error message "File permissions for document or drive" always appears. I can’t edit the files, only view them. What to do to remove this?

SHARE
Best Answer by Sharath Reddy
Answered By 0 points N/A #140680

Error Message When Opening Docs in Flash Drive

qa-featured

Here’s what you can do. Try right-clicking on the files on the USB and then click "properties”. On the lower portion of that there’s a group of checkboxes there that say’s “Attributes”. See to it that the “read-only” check box is not active or checked. You can also do this by clicking the “start button” then type “CMD” and then press enter. Now that you’re in “command prompt”, type in which drive your “USB” is mine is at “F:” so I’ll type “F:” then press enter. After that, type in “dir” and then press enter. This will tell you what files you have inside the USB. So what you’ll want to do is to change the attribute of each file. So what you’ll do is type “attrib” space, type in the file name, say for example “john.doc” space, type in “-r” and then hit enter. This will disable the “read-only” attribute of the file that you have. Hope this helps.

Best Answer
Best Answer
Answered By 564895 points N/A #291247

Error Message When Opening Docs in Flash Drive

qa-featured

One possible reason for such error is the attribute of the file. A file can be set with three different attributes: read-only, hidden, and system. The “read-only” attribute sets the permission for the file. If this attribute is enabled or checked, the file can only be viewed or opened. You can edit it but you cannot save it using the same filename.

The “hidden” attribute sets the visibility of the file. If this attribute is enabled or checked, the file is hidden in the drive. The last attribute, “system”, sets the type of the file to “system” making the file a system file. System files are normally found on the operating system.

If you have an Office Word document and you have this error when you try to edit the file, it is possible that the file is read-only or the read-only attribute is enabled. To be able to edit and save changes to the file, you simply need to disable the read-only attribute. To disable the attribute, right-click the file and select “Properties”.

In “General” tab, in “Attributes” at the bottom, uncheck “Read-only” and click “OK”. And that’s it. You can now open, edit, and save changes to the file.

Login/Register to Answer

Related Questions