An error from Keynote about needing a newer version

Asked By 0 points N/A Posted on -
qa-featured

Hi,

I have Keynote installed on my computer for creating presentations. Recently I have been seeing an error from Keynote about needing a newer version. What’s that?

You need a newer version of keynote to open this document.

You need a newer version of keynote to open this document.

View www.apple.com/iWork to learn more.

SHARE
Best Answer by RubyIslam3
Answered By 0 points N/A #170916

An error from Keynote about needing a newer version

qa-featured

The reason for this error is most likely a problem with the association between your Keynote files and the application itself.

1. Open the Finder and select Keynote.

2. From the File menu of the Finder, choose Get Info and from Open With, choose the Keynote version you have.

3. Click Change All. This should make all the Keynote files open with the right version.

 

Best Answer
Best Answer
Answered By 70 points N/A #170917

An error from Keynote about needing a newer version

qa-featured

The message saying you require a newer version indicates which you saved from a newer version & tried to open with an older version. This has nothing directly to do with whether the document was compressed & packaged in a .zip file.

If you have two versions of Pages on your PC, you have to take care to note which of them you are utilizing. You might want to erase a Dock alias to the older version & you might require to change the Finder preference for which version is set to automatically open .pages files.

Answered By 30 points N/A #170918

An error from Keynote about needing a newer version

qa-featured

Hi

The app might be having trouble recognizing the type of files it should open. Anyway, pay a visit this Techyv link for more information regarding on this issue : Document error on Keynote on my Mac OS

Login/Register to Answer

Related Questions