Error Connecting to Oracle database when installing IBM

Asked By 0 points N/A Posted on -
qa-featured

Hello,

While I was trying to connect to Oracle Database on Windows Server 2008 this message box appeared. I have checked my Internet connection and it works just fine. I rebooted the PC hoping that I will connect but it didn’t work. Can anyone help me please to fix this error ? Why I cannot connect ?

Thank you !

Could not connect to Oracle database (TCLS17) . Reason: Unknown error: Attempt to load Oracle client libraries threw BadImageFormatException. This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed.

SHARE
Best Answer by Lee Kevin
Best Answer
Best Answer
Answered By 0 points N/A #179853

Error Connecting to Oracle database when installing IBM

qa-featured

Hi Luis,

1) The reason for such a problem is  System Architect is a 32-bit application and requires that the 32-bit Oracle client be installed.

2) But you have only installed the 64-bit Oracle client. You should check the requirements for IBM Rational System Architect to communicate with Oracle on a Windows Server 2003 64-bit operating system.

3) For the solution of the problem you can Install the 32-bit Oracle client. Once the 32-bit Oracle provider has been installed on the 64-bit operating system, you will be able to connect to the Oracle database using System Architect, System Architect Encyclopedia Manager for Oracle & System Architect Catalog Manager.

Hope this will help you.

Answered By 0 points N/A #179854

Error Connecting to Oracle database when installing IBM

qa-featured
Hello
 
To install x86 and x64 Oracle client on one machine:
1- Remove any installed oracle client
2- Download and install Oracle 32-bit
3- Download and install Oracle 64-bit in a different folder
4- Run command line and go to the C:WindowsSystem32 and create a symbolic link ora112 in C:Oracle11.2Client_x86
5- Modify PATH environment and replace all entires like C:Oracle11.2Client_x86 and C:Oracle11.2Client_x64 by C:WindowsSystem32ora112
6- Set your ORACLE_HOME to C:WindowsSystem32ora112 if needed.
7- Go to the registry and follow the path : HKLMSoftwareORACLEKEY_OraClient11g_home1ORACLE_HOME
8- Set value to C:WindowsSystem32ora112
 
 

Login/Register to Answer

Related Questions