Error on Clicking Links for Sending Mails

Asked By 0 points N/A Posted on -
qa-featured

I have Outlook 2007 and whenever I clicked on a hyperlink to send an email,

I always get error stating that the default mail client is not properly installed.

I have set my Outlook as my default mail client. What can I do now?

Windows Internet Explorer

Could not perform this operation because the default mail client is not properly installed.

SHARE
Best Answer by Marie Chan
Best Answer
Best Answer
Answered By 0 points N/A #124704

Error on Clicking Links for Sending Mails

qa-featured

Check if your IE is set to send email through Outlook.

Follow these steps:

  1. Open IE, go to Tools at the top and choose Internet Options
  2. Change the default email to Outlook 2007 in the Email box and click Apply
  3. Click Apply and Ok

Try to send an email through a hyperlink. If that doesn't work, continue below:

  1. Open your Windows Explorer through Accessories.
  2. Go to Tools and Folder Options
  3. Look for File Types and URL:MailTo Protocol
  4. Click on Edit and type the following under Application used to perform action:"C:Program FilesMicrosoft OfficeOffice12OUTLOOK.EXE" -c IPM.Note /m "%1"
  5. Close the windows by clicking OK

Good luck!

Hope that helps!

Answered By 0 points N/A #124705

Error on Clicking Links for Sending Mails

qa-featured

Hi Ray,

Just because a program is set as default doesn't mean that it has assumed all the default roles available to it.  In the case of Outlook 2007, there are 13 total defaults that it can be assigned and it should have all of them. 

It is possible for Outlook to be the default for email, but not the default for email links in web pages.

Under 'Default Programs Set your Default Programs', make sure that, in addition to being the default email client, Windows Mail has all possible defaults assigned to it.

In the "Search Programs and Files" in your bottom left, type "Default" then click "Default Programs" when it comes up and click "Windows Live Mail" and then on the right side of the window check for where it says "Set Default Programs," set this as your default program. I hope it might help.

Zorian

Login/Register to Answer

Related Questions