Error-61499 and error in the LabVIEW FPGA Module have occurred

Asked By 30 points N/A Posted on -
qa-featured

Hi,

I am working with a compactrio and Labview 9. Everything compilation was ok, I have done many times, and the VI worked according to my expectation the real time hardware communicating was going well, until labview started giving me an error while the compiling the code of the FPGA.

I happen after the in-between file window closes, but before compile server started. I tried with new project in that have given only an analog input with an indicator connected with it, but still I am getting compilation error.

Attached are the error messages what I will get.

I have checked the error 61499 I didn’t find any solutions. To one of the forum they refer to the bounds of the front panel of two VIs. I have replaced them with a backup. And I did what all possibilities with VI nothing worked. Another error is:

An internal software error in the LabVIEW FPGA Module has occurred

An internal software error in the LabVIEW FPGA Module has occurred. Please contact National Instruments technical support at ni.com/support. 

Additional Information:
 
Original error message:
————————- 
 
Error 1 occurred at Generate User Event in niFpgaCompileManager_WaitForCompilationStatusDialog.vi->niFpgaCompileManager_InvokeCompilationStatusDialog.vi->niFpgaCompileDownloadRun.lvlib:cdrSynthesizeDesign.vi->niFpgaCompileDownloadRun.lvlib:nirviCompileDownload.vi->hardware_template.vi 
 
Reason(s) maybe: 
 
LabVIEW: An invalid input parameter. For example if the input is a path, the path might contain an invalid character by the OS such as? Or @. 
========================= 
NI-488: Command requires GPIB Controller to be Controller-In-Charge.

I don’t want to reinstall my applications. Can anyone help?

Thanks.

SHARE
Answered By 0 points N/A #140607

Error-61499 and error in the LabVIEW FPGA Module have occurred

qa-featured
Hello there Roger,
 
Looks like something went very wrong with your software.
 
You can try a few workarounds to see if it will help:
 
Try changing the compiler Design Strategy to Timing Performance. You will find that option under the properties of the FPGA target in your project.
 
Xiins Options
 
You can also try deleting the file perl58.dll as that is the problem that is causing the problem. 
 
If none of this helps, you will unfortunately have to reinstall the software.

Login/Register to Answer

Related Questions