Error 1402 on Kaspersky Internet Security 2012 Installation

Asked By 0 points N/A Posted on -
qa-featured

I have Kaspersky Internet Security 2011 installed on my Windows Vista PC for few months now.

It was working well and very efficient to use.

But since the 2012 version is already out, I decided to upgrade into it.

But when I was trying to install the 2012 version, I keep getting an error:

Error 1402. Could not open key: HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsNTCurrentVersionWinlogonNotifyklogon. Verify that you have sufficient access to that key, or contact your support personnel.

I called some support from Kaspersky but their solution to put a script didn’t help me resolve the issue.

I really need to install the new version since I already uninstalled the previous one.

I tried to access the key given in the error message but I was unable to.

What should I do with it?

Help please.

Thanks.

SHARE
Best Answer by mpilas
Answered By 0 points N/A #124205

Error 1402 on Kaspersky Internet Security 2012 Installation

qa-featured

Since you are upgrading the antivirus to version 2012 then I will recommend that you uninstall any previous version completely, but you will need to keep only the activation data option which is ticked in the uninstall wizard if you wish and after that you will need to  reboot the computer before you go on with the installation of the new version.

That step is crucial for any upgrade that you make on kaspersky antivirus between whichever versions. In case you previously have had other anti-viruses that you have installed then I would recommend you remove them for having more than one antivirus on a computer may cause them to clash.

Experttechyv

 

Best Answer
Best Answer
Answered By 0 points N/A #124206

Error 1402 on Kaspersky Internet Security 2012 Installation

qa-featured

It has something to do with the authorization problem for the psf keys. You may need to apply all the changes from the parent folder which is the “Domain”. The keys were made from a user that did not exist. Meaning it doesn’t have any owner so it doesn’t have any permission.

Before doing any changes on your computer, make sure that you backup your registry. Just incase if the changes you will be making doesn’t work correctly.

Click on Start, select Accessories, Select Run and type Regedit.

Navigate HKEY_LOCAL_MACHINE/SOFTWARE/WOW6432NODE/MICROSOFT/WINDOWS/CURRENTVERSION/INTERNET SETTINGS/ZONEMAP/DOMAINS

Try to click on psf and .psf. You should be getting an “Access Denied” message, because it doesn’t have an owner.

Highlight the domains and select edit on the menu bar and select on permissions. Make sure that Creator Owner, System, and Administrators all have full control so nothing will be denied.

Delete the group called “Administrator”. Add a group, and name it as “Administrators”. It is important that you add “s” on Administrator”.

Click on Advanced. On the permissions tab, make sure that all users allow in the type field. Below, you will see a box then “"Replace all child object permissions with inheritable permissions from this object". Then Click on “Apply”.

On the owner tab, the current owner should to be SYSTEM or ADMINISTRATOR. (SYSTEM is preferred).

Click Replace owner on sub-containers and objects. Select “Apply” then click “Ok” and close the permission box.

You can now click on psf and .psf keys with no access denied errors.

Answered By 0 points N/A #197875

Error 1402 on Kaspersky Internet Security 2012 Installation

qa-featured

Hi Micheal,
The error is because there are insufficient permissions to the registry keys.
To resolve this error follow the steps mentioned below:
1) Click 'Start', type 'run'
2) Type 'regedit' in the run box
3) Navigate to the following path: 'HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionInstallerUserDataComponents'
4) Right Click on the key and choose 'Permissions' option
5) In the permissions box, Click 'Add' button
6) Add the 'Administrators' account, Click on 'Advanced' tab

Security-settings-in-permission-window
7) Click 'Permissions' tab, Check the 'Replace all child object permissions with inheritable permissions from this object' checkbox
8) In the 'Owner' tab, select 'Administrators', enable the checkbox 'Replace owner on sub containers and objects'

Owner-settings-in-permission-window

9) Click 'OK' and return back to the registry editor
10) Run the Microsoft installer as Administrator

Login/Register to Answer

Related Questions