Error Deploying My Work In cRIO-9104

Asked By 0 points N/A Posted on -
qa-featured

Has anyone encountered this problem?

I was in the middle of deploying my work in cRIO-9104, but it “completed with errors”.

I was working with an NI-9853 at that time.

I got a screenshot of the error during the Deployment progress.

Deploying CAN Mode.ctl (2.09 K)

Deploying ncclose.vincClose.vi loaded with errors on the target and was closed.
LabView: Failed to load shared library nican.*:
ncCloseObject:C on RT target device.
Deployment completed with errors

Please, I need help working around this problem.

Thank you

SHARE
Answered By 0 points N/A #124729

Error Deploying My Work In cRIO-9104

qa-featured

 

This error resulted from NI-CAN driver which has not installed in CompactRIO. NI-CAN driver is required to be installed on both development machine and CompactRIO. This issue can be fixed in Measurement & Automation Explorer (MAX) by following the simple steps provided below :

1.    Firstly, open the controller and right-click on Software.

2.    Next , select Add/Remove Software and click Custom Software Installation.

3.    Select Next  and choose NI-CAN.

4.    Finally, click Install the feature.

I hope this little help benefit you . Thanks .

Login/Register to Answer

Related Questions