Enterprise manager configuration failed due to the invalid hostname error

Asked By 0 points N/A Posted on -
qa-featured

I was trying to create an Oracle database in the office using Database Configuration Assistant when I got an error message about invalid hostname.  It’s our standard to use underscore in our in filenames, though. 

Is there other way to resolve the issue since I am not adept on EMCA scripts?

Database Configuration Assistant

Enterprise manager configuration failed due to the following error –

Invalid Hostname isvp14 _ ora storage tucson.ibm com. Hostname should not contain underscore _in it.

Refer to the log file at

/u01/app/oracle/cfgtoollogs/dbca/testorcl/emConfig.log for more details.

You can retry configuring this database with Enterprise Manager later by manually running /u01/app/oracle/product/11.2.0/dbhome_1/bin/emca script.

SHARE
Answered By 0 points N/A #155175

Enterprise manager configuration failed due to the invalid hostname error

qa-featured

MPhilips, here you query can be solved by reconfiguring the software and the hostname.

It is most probably you set your hostname as a joined name instead of a name separated with the underscore

Ensure your hostname is set as; SETORACLE_HOSTNAME=127.0.0.1

You also need to confirm that your version is supported by your windows version, otherwise you may have to upgrade the system of your computer.

Open the registry and change the following settings into a machine name;

%ORACLE_HOME_NetworkAdminListener.Ora

%ORACLE_HOME_NetworkAdminTnsnames.Ora

Go to Start->My Computer->Temp and open the following;

C:WindowsSystem32driversetchosts.

In the Temp folder, under local hosts line,ensure to include the following;

127.0.0.1                localhost

172.116.113.128   mclaughin11gmaclaughin11g.techtinker

You can also uninstall and reinstall the software while deleting the temporary files to see whether it will work.

It should solve your query

Thanks

Login/Register to Answer

Related Questions