Enter key is not working when browsing

Asked By 200 points N/A Posted on -
qa-featured

Hi,

I am really having lots of computer issues and thank God some other was resolved already.

I am now having an issue with the enter key whenever I am browsing. Whenever I want to go to a website and I already have typed the address, I will need to use my mouse to get into that website as pressing the enter key will let it go.

On the other hand, when I use it on a word pad, enter key is working perfectly.

Any ideas on this?

Awaiting your answers.

SHARE
Best Answer by azestill
Answered By 0 points N/A #111571

Enter key is not working when browsing

qa-featured

Hi Emily,

There are several things that can cause this issue. I may provide you with some basic troubleshooting steps:

1. Check if the Enter key is stuck.
2. Restart your computer.
3. Make sure that before the Windows logo show up, please hit F8 repeatedly. 
4. Select the Safe Mode option.
5. Press the Enter key. This will take you to the Safe Mode.
6. Follow the all the steps requires. 
7. Once done with all the steps, please restart your computer to lead you back to the Normal mode.
 
Good day!
Best Answer
Best Answer
Answered By 0 points N/A #111573

Enter key is not working when browsing

qa-featured

Hello Emily,

We had the same problem encountered. And I know it is time consuming since we are used to press enter after typing the address on the address bar. Here are some causes of your problem. And maybe one of this can be a solution.

  • It may be a browser related issue (Firefox, Google Chrome, Internet Explorer problem) specially after upgrading/updating it.
  • It can also be caused by your anti-virus software such AVG which contain the feature plug-in (AVG Safe SEARCH) that avoids any malicious sites. This plug-in may be incompatible with your browser. You can disable this by:

If you are using Firefox browser just go to Tools > Add-ons > Extensions then locate "AVG Safe Search" then select disable.

If Internet explorer: Go to Tools > Manage Add-ons > Enable or Disable Add-ons then disable"AVG Safe Search" –>

Tools > Mannage Add-ons > Enable or Disabel Add-ons then disable"AVG Safe Search Tools > Add-ons > Extensions then locate "AVG Safe Search"  then select disable.

If your using Google Chrome Just click on the wrench picture >Tools > Basic > Search > Then replace manage search engine with Google. Thank you I hope that helped.

Login/Register to Answer

Related Questions